Trouble making a set of glyphs smaller

I have a font where caps and normal letters are all the same size. I experimented trying to make the regular letters all 80% size of caps. I did this by selecting all of them, going to filter, then transformations then transform, then in the scale section I entered 80%.

In the app, using the text tool, indeed the non-caps are now smaller. However I have 2 problems:

  1. When I export the font, using Pages, the caps and non-caps are all the same size still.
  2. In the app, where indeed the non-caps are now smaller, their position is too high. I would like them to all be aligned to the bottom in the same way as they originally all lined up. Now they are all lined up to the top instead, except even their tops are a bit higher than the caps letters. How can I fix that, for the whole group?

Many thanks!

This is probably a font cache problem. Read this please:
http://www.glyphsapp.com/tutorials/eliminating-font-cache-problems

This sounds like the transformation origin was not set correctly. Should probably have been Baseline. To fix this: Determine how far off the baseline they are, and then apply Filter > Transformations > Transform > Translate Y with the negative amount. E.g., you find out your glyphs are 56 units too high, you do this:

image

1 Like

They’re only -1 from the baseline, and both X and Y were set to 0 in that menu in your pic. So, can we deduce that this was not the cause of the problem?

There is says:

So, you install it in the system by either opening it in Apple’s Font Book app, or by using a third-party font manager, or by simply dragging the font file into ~/Library/Fonts/ .

Well, you shouldn’t.

Why not? Because installing a font with the same name as a previously installed one can seriously mess up your font caches

I did follow instructions from a tutorial video I watched, each time saving a new version of the font I’d go to info and change the name of the font. I’d add a consecutive number at the end. Unusually, with this particular one, instead of each font showing up in Pages with the numbers next to them, this one did not apply that new name to the exported .otf file. It just kept the old name. I tried again now and each time it’s the same. Even though on noticitation that it exported, the notification calls it by the name I entered in that info place. Also, the actual file Glyphs file name is different from either of those, so, it shouldn’t be that that’s causing it.

So it seems the same file name is the thing that’s causing the problem. How can I make it use the font name I enter into info?

Thanks!

Oh and on the plus side, I restarted Pages and now indeed the non-caps are showing up smaller!
So, just left to solve:

  1. Why it’s not naming the files as I made them
  2. What is causing the odd position of the non-caps and how I can fix it.

I just thought, I think it may be taking the line at the top (I don’t know what that line is called) as the focal point of the transformation, instead of the baseline. That’s what it looks like eying up the geometry of what has happened. So now I’m looking at a thing in the transformations menu which says origin. I think I’ll try switching that to baseline and perhaps that will fix it!

Hoping that works, this will leave only number 1) above :slight_smile:

The file name is derived from family and style names. What do you have entered there and what exactly is the resulting file name you get?

Alternative: you can set the file name directly with a custom parameter in File > Font Info > Instances: the parameter is called fileName and takes the file name without suffix as value.

1 Like

Many apps need a restart for rebuilding their font menu. I believe Pages does its own caching on top of the system font caches. That is why I do not recommend testing unfinished fonts by installing them in the system. You will run into font cache issues, and you will spend half of your time debugging cache problems. Do yourself a favour and use the Adobe Fonts Folder, or an HTML/CSS setup with a web browser (there is a mekkablue script Test > Webfont Test HTML that does exactly that), or the free TextPreview app.

1 Like

So for example I can name the font ‘Pickles are nice’, and the exported file to the font folder still is named the old, original name of the font (I did not create it, just using it to practice making changes to). But it is my new version. And strangely, it appears as ‘Pickles are nice’ in Pages! But the old font, ‘Pickles hmm’, and the original before that version - the original before I took it to play with - are gone from the menu. It just keeps writing over the .otf file.

Also opening this .otf file with Font Book makes it show up once in Font Book not with the otf file name but rather Pickles are nice.

That issue I think is because of Glyphs saving under the same name instead of changing it. So would be great be able to find what’s going on with that… is there a way I can get that method working? In the meantime I’ll try to " File > Font Info > Instances…" work around, thanks!

Also another question comes up now. The baseline thing is sorted now, thanks! But, the non-caps now all have kerning issues. Is there a way to make the kerning behave in the same way it did, proportionally, to when they were full size? Or … what can I do to make the kerning appear the same (but everything smallened) as the full sized versions?

Thanks for your help!

In that place, there are two custom parameters. postscriptFullName, and postscriptFontName - and their value is set to the original font’s name. Might it be this causing the issue? Should I just delete those parameters? Or will that cause a problem - if so I should rename one or both of them to the new name?

Thanks!

If you want me to help you, can I get an answer to this question:

The file name is derived from family and style names. What do you have entered there and what exactly is the resulting file name you get?

Have you opened an existing font? You can get rid of these parameters then. Please read this:
https://glyphsapp.com/tutorials/importing-existing-fonts

1 Like

From info I go to font tab and in Family Name I set it to: Pickles are nice
I don’t see a box for styles name. Is that somewhere else? With my other font I could change just this family name and it made the .otf file names export same as this.

Yes, as I said, I took an existing font and am altering it to practice as I’m new to this app.
OK so I will delete those parameters, perhaps it will fix it! And I will read that link, thank you!

So I got rid of them. Though something unexpected - while it does adpot my new Font names now, it added a suffix. The file is now:
Piclesarenice-Regular.otf

Is that ok or, how to just make it without that suffix?

‘Regular’ is the style name. You will find it in Font Info > Instances. A font family can have multiple instances/styles, they are defined there.

1 Like

Thanks, that’s it!
It’s looking good now, thank you!

Rather than starting a new thread… just tried editing another font to add macrons. All fine when I add glyphs entitles Amacron, amacron, Emacron, emacron, same with I,i,U,u… until I get to o. The Omacron is fine, but then trying to make a glyph omacron, it says:
A glyph with the same Unicode is in the font already: omacron

When I search the font for 014D, the using the search function under all category, it gives only one result, and that is Umacron. That’s odd, because even right there on that screen, the Ū appears with the code ‘16A+’ on the bottom right. Hmm… now I notice the others don’t have + after the code, so that would seem to be connected to the issue… I can just scrap that one I guess and make a new one… yup, that worked. Strange behaviour though. Perhaps I had named the file omacron and then seconds later renamed it Umacron, I do remember making one naming error briefly. That was before I even turned it into a Component Glyph I believe, so, it’s weird it ended up with a + and somehow behaved as though it had (its old?) name.

U+014D

Suggested readings:

The plus sign after the code means that the glyph has multiple Unicode values assigned. A typical strategy for single-case fonts (usually all-caps):
https://glyphsapp.com/tutorials/creating-an-all-caps-font

Diacritics:
https://glyphsapp.com/tutorials/diacritics

1 Like