Tunnify stopped working

I’m not sure when it happend, but it doesn’t work anymore. My version of Glyphs is v. 2.3b (870).

Works fine for me in 873. When was the last time you updated the scripts?

I don’t remember, but I redownloaded now and restarted Glyphs. Still doesn’t work.

Perhaps try updating your modules in Preferences > Addons > Modules.

Any error messages in the Macro Window?

Still no response.

The error message tells me that you are not running the latest version of the script. Line 11 looks like this: https://github.com/mekkablue/Glyphs-Scripts/blob/master/Paths/Tunnify.py#L11

selectedGlyph = selectedLayer.parent

And in your version, it was still:

selection = selectedLayer.selection()

This was changed some 6 months ago. How did you update your script collection?

Downloaded zip from Github, replaced in script folder.

Well, something must have gone wrong in the process, I assure you the error message is not from the current version. Can you please try again? Delete the old ones first perhaps, then redownload and make sure you pick the right ones in the download folder of your browser. Perhaps also delete old downloads first.

I deleted the old scripts before copy-pasting them again. Works now. No idea why.