Turn off snapping except grid

Snapping to every existing element is just nuts.
If i could just turn it off and stay with snapping to grid it would be one step in the right direction.

Right now to regain control over the points i have to either zoom in really close or jump to arrow keys which i don’t really like in the first stages of work… Pressing ctrl doesn’t really work because it only works for regular point manipulation and i’d like to use all the shortcuts like alt or ctrl+alt.

I started asking them to move where i wanted them to move, so i figured it’s a good time to write about it here…


Didn’t find it earlier. I think it illustrates the problem well.

can u plz, update the link? have the same question )

Three options:

  1. Temporarily deactivate snapping by holding down Ctrl.
  2. Install Snap Killer from Plugin Manager.
  3. Paste and run Font.snapToObjects=False in the Macro Window. Disables snapping completely.
1 Like

Thanks so much for the flag to disable it.
I encountered, that Font.snapToObjects=False also breaks the angle constraint when holding shift and moving nodes. Is this on purpose, or a bug? I think those are 2 different things and the latter should not be disabled, as one deliberately wants it when holding shift. Or?

It seems that the snapping and the shift constraints are handles in the same place that the setting is cutting both off. I’ll have a look.