TypeError: 'int' object is not callable

Getting a type error in macro when executing any range(x).

Should I be importing any library for this to work?

Can you post a bit more context?

It sounds like that you have a variable named ‘range’. That overwrites the range() function.

No, not really. Here is the same result with a new empty file & macro.

Then you maybe have installed a plugin that messes it up?

Thanks, Georg. Didn’t know that this might mess things up.

Moving the plugins in and out of the folder fixed it.

Though I still wonder how come this fixed it, coming from the fact that it still uses all the same plugins in the end.

Happens when you run code (i.e., the plugin in this case), that leaves the variables around. Can you find out which plugin messes it up?

I tested all plugins and they are all good. My best guess is a residue of a script I have written, but still don’t know how moving the plugins in and out helped [smile].

Maybe it was not the removing but the restarting of Glyphs?
You can search in all of your scripts for range =. Maybe it was just a mistyping.

Yes, it is probably something like that.

On the other hand I did restart a few times.

Anyhow moving the plugins worked out nicely, so a happy result nevertheless.