UFO import: composite glyphs with switched components?

  1. Open cr.zip (366.0 KB)
  2. Check composite glyphs such as f_f_l, dzcaron and Abrevetilde

I exported the font from the original FontForge source to UFO and checked with Trufont, all glyphs are displayed correctly there. Importing the UFO into Glyphs v.2.4.2 then switches composite letters around, Abrevetilde is… pushed up? Not sure what’s going on here, a bug in my sources or in Glyphs?


This has to do with the automatic alignment. You can set it to be disabled for imported fonts in the preferences.
The order of the components does not match the visual order. It than the automatic alignment is applied, the actually order is used to position the components.


I’ll go with automatic alignment, but how do I change the order?

Also: It looks like I can’t use dotaccentcomb as a component for dotbelowcomb, unless I want to have circumflex attach to dotbelow. Can I do something about that?


Either use the Fix Compatibly filter or cut/paste the components in the right order.

Put the drawing of the dot in a glyphs that has no anchors and use that as a component in both the above and below mark.


Thanks, that helped.