Unable to change kerning

This is happening for all pairs in a particular master. When I enter values they are reset to zero, when I click on the lock to unlock it automatically re-locks again. I can’t see anything unusual about that master.

Do you have a metrics linking custom parameter?
Can you send me send file?

Sorry, update to 3225 fixed it.

Oh dear me. This was entirely user error. I had changed the layer I was looking at by clicking on the layer list, instead of changing masters with the master selector in the toolbar. This left me trying to kern a layer from master B against master A.

Maybe there are UX lessons to be learnt here, but I’m not sure what they are.

Good point. I disabled the kerning UI in the info box if the layerIds don’t match.

What about alternate layers? I’m just wondering. Was it possible until now to set kerning for alternate layers? In that case, the layer IDs also wouldn’t match, but kerning should still be possible.

I don’t think that this would have worked. Kerning is always stored by masterID, so sublayers will always inherit the kerning from the master.