Unable to export Fontlab vfb > Glyphs via GlyphsExport.py

I’ve decided to make the leap from FL 5.etc to Glyphs. Downloaded Georg’s export script from GitHub (thanks, @GeorgSeifert!) and installed it in the appropriate FL Macros folder. When I run the script I get the following error message:

File “”, line 573
ProposedFileName = ProposedFileName if ProposedFileName else “”
SyntaxError: invalid syntax

Is there a setting within FL that needs tweaked to make the script run smoothly?

How did you download and install the script?

  1. Download the whole repository with the green Clone or Download button.
  2. Move the Glyphs Export.py and Glyphs Import.py files into the FL Macro folder.
  3. Reload the scripts in FL. There should be a reload button in the Macro panel.

Thanks for replying so quickly! Those three steps are exactly how I downloaded & installed the script.

I’ve run the script with several different vfb files, as well as in both FL 5.2.2 5714 and 5.2.1 4868 (Windows). I get the same error each time, which makes me think perhaps there’s an issue with the way I set up the file info?

can you open the macro editor in FLS and run this script:

import sys
print sys.version

and post the result? I suspect that you have python 2.4 and the scripts need 2.7.

You can also try this: http://blog.fontlab.com/font-utility/vfb2ufo/ it will convert the .vfb to .ufo that can be opened in Glyphs.

Well Georg I just face-palmed. I was using 2.4; I thought I’d upgraded but apparently not!

After installing 2.7.13 today, I’m unfortunately still getting the error message with all .vfbs. Going to give the utility you linked a shot & see if the .ufo works better. Thanks!