Unable to install new scripts

I followed the advice in http://www.glyphsapp.com/forums/index.php?action=vthread&forum=2&topic=1930 but unfortunately, none of the scripts “Autopsy.py”, “Center Glyphs.py” etc. appear in the menu. I tried to reload the menu with Cmd-Opt-Shift-Y but the scripts don’t appear.

When I open the scripts’ location, they are there. Any advice on that?

Are you sure you have used the right folder? You can open the correct location from the script menu.

When I open it from the script menu, it is located in
Macintosh HD/Benutzer//Library/Containers/com.schriftgestaltung.Glyphs/Data/Library/Application Support/Glyphs/Scripts which is different from the path mentioned in the manual. I put the scripts in both locations, but it still does not work.

I installed my version from the Apple Store.

Tried restarting the app, logging out and back in again?

Yes, I have tried that – still no success.

Does it work in a different user?
In the worst case, delete and redownload glyphs from the AppStore.

It does not work with a different user either.

The Script Menu says, its scripts are located under

Macintosh HD//Library/Containers/com.schriftgestaltung.Glyphs/Data/Library/Application Support/Glyphs/

When I put a script in there, it does not show in the Script Menu.

I uninstalled Glyphs before and reinstalled from the Mac App Store.

I am not sure if I uninstalled the Glyphs App in the right way. I just dropped the App. Is there any better way to uninstall Glyphs completely, including emptying any caches?

No, that should do. I assume it is a bug in the latest version. Which version of app and OS are you using?

I just encountered, that my aliases don’t show up in the script menu anymore.

For several reasons I got all my scripts somewhere else and put folder aliases in the Glyphsapp script folder. This was fine over the years. And it’l be nice to keep. Could it be caused by Yosemite? Non-alias folders work.

[Glyphs Version 1.4.5 (614), Yosemite]

Yes, Yosemite does Aliases slightly differently. But this should be fixed. Try re-creating those aliases.

interesting. recreating doesn’t help though. tried it several times (also renaming or keeping the given alias name etc)

Do you have the App Store version? The fix is not in that version yet, I believe. Will ask Georg.

old-school-non-App-Store-version :slight_smile:

I cannot reproduce it. It works in Version 1.4.5 (614) on OS X 10.10.1 (14B25). If you do not have that version, try Glyphs > Preferences > Updates > Show cutting edge versions and click Check now.

I got that switched on, too. last check today at 6. I now thought about the fact, that the target folders are in the dropbox? But after trying to make an alias targeting a »normal« folder it didn’t help as well. For now only the scripts in the actual script folder work.

Does it work with Glyphs 2?

Good point. Yes it does work there.


I now installed Yosemite fresh from the Store, and Glyphs from the App Store – same problem: When I put a script like “All Anchors in All Layers.py” in the script folder, it does not show up in the menu.

I got Glyphs Version 1.4.4 (609), Yosemite 10.10.2.

Is there any way to switch from the App-Store-Version to the downloadable version?

I even tried Glyphs 2 – same problem.

When I try to open the .py-Script, it says that Xcode is running from a volume that does not support ownership. “Please move Xcode to one that does.” I tried and fixed that. But it did not help.

The functionality of Python scripts has nothing to do with Xcode.

Can you try and restart your Mac in Repair Mode (Hold down Cmd-R), and repair permissions and the volume with Disk Utility?

If that does not help, there seems to be something wrong with your OS X installation. Do you have any system extensions installed, e.g. MacKeeper?

I repaired the Disk in that way. Actually, some issues were found. After a second run, no more issues were found.

Afterwards, I uninstalled and installed Glyphs again.

I don’t have MacKeeper installed. I had the extension Boxcryptor installed, but even with a disabled Boxcryptor, the problem still exists. Any other hint?