Unable to paste from Illustrator?


Not sure if it’s coincidence, but since upgrading my Mac to a new M1 chip version, I can’t paste from Illustrator into Glyphs anymore. I just get the spinning beachball of death for a while, and then nothing. I had been trying to install Python to get some scripts loaded, so could this have affected it?

This is a bit of a problem for me, as most of my character sets I’ve made over the years are all in Illustrator!

Any ideas please!?


Glyphs 3.0.1 / MacOS 11.0.1 / Illustrator 25.1

Try the latest beta please. Go to Glyphs > Preferences > Updates, activate both checkboxes and press the Update button.

Thanks – tried that now, but still not working?

here are some basics, might help, https://glyphsapp.com/learn/importing-from-illustrator


Thanks – most of this I’ve already done. The issue is the character glyph I’ve drawn in Illustrator not pasting at all – I just get beachball of death, and then nothing. It was fine up until I moved Macs and installed the Python 3?

That has nothing to do with python. Can you send me the .ai file? And can you check the clipboard settings in Illustrator?

Possibly not – just seems a coincidence!

Illustrator preferences have include SVG checked. I’ve also tested it with a new Illustrator document and new Glyphs font file, but the same happens, so it can’t be specific to the file.


Can you set the clipboard preferences to PDF and not SVG? That seems to be a new options that I didn’t see myself. I’ll have a look.

I’ll try that and see if it makes a difference!

Hi - tried changing the Clipboard settings but that hasn’t resolved it.

Also saw the update, so installed that, and that hasn’t resolved it either. Not sure what to try now? What’s the best way to completely uninstall it so I can start from scratch. I might uninstall Python too, incase that is affecting it.

I had used my App Zapper uninstaller before to try and remove it, but there must be a preference left somewhere as the app was still recognising my files in the opening window?


Uninstalling and python has nothing to do with that. Can you send me the .ai file?

Yes, but it’s happening from any Illustrator file, not just the one I had been working on.

I have just tried the same on my MacBook Pro (11.0.1), updating to 3.0.2 – and it’s still working fine (Python not installed on this Mac). So is this likely something still with the M1 Silicon chip?

We are asking for the file to see what kind of graphics you are trying to paste. That may make a difference.

Have sent the file to Georg.

I’ve tested it with characters, and simple shapes in clean Illustrator files and new Gylph files, so not sure it’s what’s being pasted is the issue?

My older intel MacBook Pro seems to still paste fine?

So maybe it`s an issue with MacOS v. ?

Don’t know – both my Macs are on the same OS version, the only difference is one is M1 and one is Intel?