Unable to run external Python

For some reason Glyphs has started failing to be able to use external Python version for me. I can still use the baked in Glyphs Python. Every script, including ones run directly from the macro panel, give me this error:

Traceback (most recent call last):
  File "<internal>", line 4
  File "GlyphsApp/GlyphsApp/__init__.py", line 642
AttributeError: Cannot replace selector 'font' in 'GSApplication' by non-selector

This started happening not long after I installed the Glyphs 3.2 alpha (which I then removed), but it could have been a coincidence. Another clue is that I tried re-installing Python just to be sure, and Glyphs doesn’t show the new Python version (3.11) as available in Preferences->Addons

Any help figuring this out would be greatly appreciated

Odd. I was able to get it working again with Python 3.9.15.
3.10.8 produces the above error, and as mentioned 3.11 does not appear available at all.

That is a problem with pyobjc version 8.5. Use version 8.4 or 8.5.1.

Scripts not working "Glyphs is not defined" - #5 by GeorgSeifert

Thanks Georg, that fixed the error

This isn’t a priority, but I still can’t see 3.11 in the Python version menu. I tried reinstalling with Homebrew to see if it was the issue (I had installed 3.11 using the python.org installer initially) but that didn’t make it available to Glyphs. Is 3.11 just not supported?

I didn’t prepare for python 3.11. Will do so soon.

1 Like