Unable to view all Master in Layer Palette

I have a font file with a lot of Masters (currently around 44 - it is a modular font with many variations). My problem is that I’m working on a laptop, and so have limited screen height. Often the Masters lower down on the list are not visible as the window often doesn’t allow you to scroll. I think this is a bug of some sort. Is there a way around this other than dragging the Masters I am currently working on to the top of the list in the Font Info dialogue? Thanks.

Typing a few returns before and after should increase canvas height and allow you to scroll.

Are you really sure you need 44 masters?

Perhaps more. It’s a pixel font where there are various shapes and they fill in certain areas. It doesn’t really lend itself to any kind of axis as I need precision and a increasing a ‘value’ fills an area by increasing the number of objects.

It’s the Layers Palette that has a problem, not the preview window. The list is longer than the Palette can show. Sometimes it allows you to scroll towards the bottom but if you actually hit the bottom, the Palette will return you to the top of the list, and not allow you to scroll this time. The only way to reactivate scrolling is to use keyboard shortcuts to change the current Master. If you do this, the Layers Palette is reset and works again.

It’s fairly easy to reproduce if you create enough Masters. I can send video if this helps.

There can’t you scroll? In the Layer Panel?

In the Layers Panel / Palette on the right hand side of the Glyphs window. Here’s a video: https://we.tl/t-IQg6F6YBAV

Can you send me that file?

Here’s a file that shows the bug. The list of Masters just needs to be longer than the height of the Layer Panel.

Masters Bug.zip (2.5 KB)

The layer panel lets me scroll wherever I like. Can you start without plugins? Hold down Option+Shift when you start the app.

I’ll give it a go.

I think the difference might be that I’m running this on a laptop screen, so the height is limited by the screen. I don’t have an external monitor to test this so I can’t be sure. I’m using OSX 10.11.6.

I just tried it with plugins disabled. It still does the same thing.

  • Consider updating to at least macOS 10.12
  • Consider using the Master Switcher plug-in
  • I cannot reproduce either. Can you make a screencast of what exactly you are doing?
  1. I have access to another Mac with 10.12 so when I get a moment I will check to see if it does the same thing.
  2. I’ll have a look at the Master Switcher plug-in. Thanks.
  3. Here is the video I posted earlier. It shows the bug in action: https://we.tl/t-IQg6F6YBAV

I just tested on a different Mac running Glyphs 2.6.1 on OSX 10.13.6. The bug doesn’t happen using this configuration.