Undo Breaks (789)

Haven’t caught exactly how yet but it happens often atm.

That is most likely caused by a plugin or script (RMX was causing it, but that is fixed now in the latest version).

I haven’t used any plugins including RMX, will try to take notice of scripts…

I was about to report UNDO problem … it occurs after running the RMX tuner.

I removed all my scripts and plugins, it turns out if I cut a path, CMD+X, I can’t undo it…

What version do you have? It works fine for me.

Says on my thread title 789, OS X 10.10.4

Can you try if the undo works before you do a CMD+X?

It works until I do a cut. It’s strange since If I open a new file and try to do a cut, undo doesn’t work. Sometimes when I am working, undo works other times it doesn’t.

Also experiencing the same undo problem. I will keep an eye on my process to detect a possible cause.

same here (789), had problems with undo, with and without using RMX… It only affects the glyph I’m working on atm. Everything seems to be fine in other glyphs though

It’s fine when I undo Cmd+X of a component btw. I had a crash before after the undo broke and I tried to redo. Will send crash report.

cmd+X works fine for me.

I’m on v 791 now, haven’t experienced the problem yet.

I’m having lots of problems with undo in 791. Undo/Redo don’t cease functioning, but it seems like not all changes are going to the undo stack. For example, I just moved a path to the background layer and deleted the foreground. Undo then went back much farther in my work history, another undo seemed to jump farther randomly, and redo then jumps to some other random spot.

Undo also seems to forget which glyph is being editing. So undo can break in one glyph and make changes in another. So I managed to wipe out three glyphs worth of work today when undo trashed two more when I was trying to fix what it trashed in the glyph I was working on.

IMO 791 is not safe to use.

1 Like

I had an undo problem when putting a node on an existing curve and then removing a node further down. Undoing the removal didn’t work. I’m on v789.

resolved >> V. 791

I’ve had very similar problems with undo of late…

Now I’m getting crashes when I do the following:

  1. Generate a glyphs instance in a MM font
  2. Add a .UFO as a master in the new .glyphs file as another master
  3. Create text tab
  4. Switch between masters
  5. Close generated instance file (still unsaved)
  6. Glyphs app crashes – every time if I follow this.


even like this:

  1. Generate a new .glyphs instance from a MM ,glyphs file.
  2. Close original MM .glyphs file.
  3. Crash, every time

Glyphs App crashed when I did a transform with background and then tried to undo that (796)