Undo does not always function

Hi there!

I’m continuing to encounter an issue while undoing.
Sometimes the Undo doesn’t work. So I have close the App and reopen it again. I didn’t find a pattern yet.

Another issue is that the Export functionality exports the .otf in the selected folder AND on my desktop (this afternoon I worked on a source file on the desktop; than I changed Mac and copied this source to its proper folder).

I see for the 2nd bug!
In the export panel There is a “Install font” option with a path below. My path was set to Desktop, but the checkbox was NOT selected.

The second bug was easy. Fixed it. Thanks for reporting.

The undo problem is a bit complicated. I know about some issues and try to improve. e.g. The undo in the Background does not work and sometime corrupts the undo state.

Ok thanks.
I found another little thing uahha… :
In the “select sample text” window, I must mouse-click to change the sample text; it would be great seeing the text refresh simply moving with keyword arrows.

Another great functionality would be to manage the max character length of the text preview, to control when it goes to the next line.

If the sample text list has the focus once, I am able to use the arrow keys. even if I reopened the window.

For the view size, I added a option to the preference.

Yes I can use arrow keys, but then I have to click with mouse to see the sample text with my font, otherwise nothing happens; or click “Enter” but the sample text window disappears.
By the way, is it possible to let the Zoom+ Zoom- short-keys enabled while the sample text window is open?

Could you also check the glyph slash “/” ? When I open it, it is blank and uneditable. To edit it I must click “T”, write “/” again, and then press “esc” to go back to edit mode. Only then I see the vector of the slash.

You are right with the sample text window and the slash. I fixed it.

Thanks for reporting.

I am still frequently losing my ability to Undo in 1.3.8.

Now also with Version 2.0.1 (729)
Undo command is dimmed
and I am unable to find a way to Revert to the last saved file version !!

I change to default of the “Use Versions” setting. It is disabled by default now. If you have any changes, there should be a “Revert” button.

What did you do to the file?

There is still the undo bug in version 2.0.1 (729). The first time it tooks 23 times to press command +z.
A screen cast of the issue here:

Thanks Nicolas
Those are Undo failures and there seem to be also problems with Snap to Grid where Undo totally cease responding !

Seems that control + or control + in Text Mode in the Edit windows is not working as a shortcut to modify the left side baring of the character.

Those shortcuts are occupied by the system (for spaces I think). You can deactivate them in preferences > keyboard …

That seems to be related that you are on the background. I’ll have a look.

Hi there @GeorgSeifert and @jan, I too am experiencing the “Undo” issue. I just bought the Full License to Glyphs and have updated the software to the latest (2.0.1).

I tried experimenting to see what the problem is, and I believe it is a Filter Plugin Issue. How I noticed it failing was when I create any shape, move it around and edit some parameters, then apply the Filter - Remix Tuner, I get this message “For single - master fonts, only slanting is available.” Then I click OK and nothing happens. No other menu appears. Then when I try to Undo, nothing changes, I hit Undo again and still nothing changes on my screen. After a few tries, the word “Undo” becomes greyed out and I can’t Undo/Redo anymore for anything I change.

I have to either copy and paste into a new document and start again. Please let me know if this can be fixed, thank you for your time!

This is a very valuable observation. I will look into it.

Thanks for looking into it Georg :slight_smile: I have sent you a crash report when using the RMX Tuner filter. I just recently bought Glyphs so I’d love to keep continuing to use the program. Please let me know when you’ve updated the software and if there is anything I can do to help fix the problem. Looking forward to hearing from you

I am finding undo in glyph edit mode pretty ineffective. While a path is being drawn, I can press Cmd-Z to undo, but each dragged handle is treated as multiple tiny steps, so working your way back a point or two is laborious. I am new to Glyphs, so unsure if this is normal. I am used to being able to undo discrete steps in AI without breaking away from the Pen tool.

Glyphs 2.3 (895) on Mac 10.10.5

You’ll get used to it. Illustrator’s abhorrent interface is only good for big sloppy changes. Font editors offer much more precision because it’s hard to draw good curves without precision.