Unicode Values Get Wiped Out when saving or duplicating a Glyph file

I am mapping out custom icon font in the private character space and assigning specific unicode values. There is a bug in the Glyphs that basically completely wipes out all of the values (the whole column is gone) whenever the file is saved (explicitly or autosaved) or duplicated.
Since I need to save my work periodically I have no choice to keep the app running for as long as I can without rebooting because if I do reboot, all of the work will be gone once I reopen the file.

I am on Mac OS X 10.7.4, Macbook Pro (latest), 16GB RAM.

Please Help!!!

This works for me.
Did you set the “Disable nice names” checkbox in Font Info > Other Settings?

Georg Seifert
Georg, I have “Don’t use nice names” set to unchecked. Should I set it to check to solve this issue?

Well. It WORKED!!!

Thank you so much for your help. I feel a little dumbfounded.

Be careful. To be compatible with some environments, it’s a good idea to stick to the standard naming scheme for the Private Use Area (PUA), e.g. uniE000 etc. For instance, OS X prior to Leopard (10.5) will ignore the set Unicode and reconstruct it based on the glyph name. Some PDF implementations do something similar.

Thank you for the tip. I am hoping that since the font will be used only to display icons on the web and nothing else, I won’t run into those issues (hopefully). Either way, I highly appreciate the tip!

I am having this same issue.

Trying to create an icon font for use on the web

I am inputting unicode values F001 - F0086 so far, font works a dream. The issue is every time I close the glyphs application it wipes all unicode values from the column, so i have to manually retype them again when i need to export the font. I have the ‘Dont use nice names’ checked.

Very frustrating as I am approaching 100 characters. Any ideas?

What did you use as glyph names?

Calling the names sequentially with the unicode value followed by a descriptive name eg. F002.categories I have also used hyphens in the name descriptions eg. F0028.r-chevron

Use uniF002 and no suffix.
Do you have Glyphs Mini? If not, you can “disable nice names” in font info. Then you could add your suffixes to the uniXXXX name and manually set the unicodes.

Fixed!! Thanks.

Just to clarify I am using the full Glyphs.
I opted to check ‘don’t use nice names’, then with the suffix I had to use a hyphen instead of a period to separate the unicode from the suffix eg uniF001-search, this then allowed me to manually input the unicode value and it now keeps the unicode value when the file is closed and reopened.

The hyphen is not a good idea. I just tried and if I use uniF001.search and set the unicode manually it worked as expected.