Unknown newGlyph

Hi, somehow an annoying glyph was created in my font but I can’t find it nor delete it. It’s called “newGlyph” and has been attributed the Unicode 000A (LINE FEED?). When I type, it shows up behind letters and messes up the texts I try to write, especially while making returns. Any hints?

What happens if you run

del Font.glyphs["newGlyph"]

in the macro window?

When I do that, the glyph remains and the following window appears:

The error message is from something else. Maybe you need to run the command more than once.

Or you could filter for the glyph in the font view and select and delete it from there?

I couldn’t find it anywhere in the font view. But it appears in the text. Super weird!

I ran into other major issues with Glyphs 3.2 so I just downgraded. Now it works like usual…

PS: This happened when I copied one layer of a glyph (¢) in one master and set it to an intermediate layer without any value. Even though I like art, I don’t think this is intended.

If the brace layer has no proper setup, it will lead to an extreme extrapolation like this if you put a component in it. So you should always setup the brace layer, first.

1 Like