Unlocked guides becoming stuck

Hi, Is anyone else noticing an issue with guidelines becoming unmovable with the cursor? They are not actually locked, and can be positioned with arrow keys. Their properties box is also missing even though I’ve ‘show info’ is selected. This means they cannot be rotated. I’ve tried locking and unlocking just in case.

I had similar situation and it resolved itself when I have changed the side-bearing to <|>. After this it was back to working properly with all settings for side-bearings. Rather odd issue.

Thanks @Realist. I think I was adding or adjusting the guide while in ‘All Layers’ selection mode. Maybe this is an expected scenario.

that might be a problem with the All Layer tool. I’ll have a look.

I cannot unlock any GuideLines once they are locked. No particular file, even in a new one. Glyphs Version 2.4.1 (965). Doesn’t work on my machine, but on another Mac with the same Glyphs Version it still works. I also removed all plugins, still no improvement.

I even cannot access them via

for gl in Glyphs.font.selectedLayers[0].guides:
	print gl.position

nor via:

for gl in Glyphs.font.selectedLayers[0].guideLines:
	print gl.position

It just prints nothing unless the GL is not global.

Global guides are not accessible through the layer (that would be local guides). Globals are in the font master.

for gl in Font.selectedFontMaster.guides:
	print gl.position

And there is a shortcut to the active layer:

for gl in Layer.guides:
	print gl.position

Thanks, good to know!

Still cannot unlock manually. The Contextual Menu on right click just doesn’t offer the entry.

Is your mouse arrow over the lock or the guideline knob (circle) when you right-click? It seems to work from a quick test with some global guidelines in Glyphs 2.4.1 (965) beta; either Lock Guide or Unlock Guide appear, appropriately, for me.

It’s not neither over the lock, nor anywhere else on a GL. Does work on all other Macs in our studio. Any idea how I can debug? I removed all plugins already as I mentioned.

Works for me, too. I have no idea.

Mouse, tablet drivers? Anything in the console?
Corrupted prefs?

Nothing special in the console.

What is a mouse or tablet driver? I did not change anything. Just using the regular mac keyboard and mighty mouse.

Where in the prefs could I check for what?

I’ll keep an eye on this issue, but for now I can move it with python, so no big deal.

Are there any special settings in System Preferences > Accessibility?

That’s so weird: I unchecked the »Spring-loading Delay« there in the Mouse & Trackpad menu. And now it works. Did not restart the computer or Glyphs since yesterday. Don’t know why it works now, but thanks for the help @mekkablue! :slight_smile:

1 Like

It’s back, cannot unlock again. Just wanted to let you know. Don’t wanna bother with it now. I’ll work around it with a script then. Strange.