Unresponsive when in Font View

I am getting the completely unresponsive spinning beachball whenever I try to scroll through in font view. Not sure if this is due to the recent cutting-edge update or due to the font file itself.

The font file is massive (1300+ glyphs and ~80 masters) (there is a separate yet related issue about making the whole file more efficient) but the strange thing is in previous iterations of a similar setup there was noticeable lag but not this level of unresponsiveness. I think it started after a test involving adding a set of intermediate masters to some glyphs.

There isn’t an issue when in editor view and, aside from the long export time, there isn’t an issue with exporting.

I’ve tried in disabled plugins mode. Also, tried a completely out-of-the-box trial version on a friend’s super upgraded MBP thinking it might be my processor not being able to handle something but it had the same result. There were no plugins/scripts/additional filters…maybe it has something to do with the default filters?

Any other ways I can check what’s causing it to become unresponsive?

3.0.5 (3124)

Do you have the text preview window open?

No, text preview is not open.

Did you start an export before?
Can you send me that file?

No export before.
Yes, sending you the file.

Thanks for the file. The glyphs with brace layers need a lot time to process the state of the metrics keys. The font is quite complex, I don’t think I have seen something like this before. I’ll see if I can improve that a bit.

1 Like