Update vanilla library

That is possible by making sure by sorting the sys.paths. It will pick the library that it finds first when going through all the paths.
So, check sys.path and are you sure you installed it correctly? Only the content of the Lib folder should go to the scripts folder.

When I try to update vanilla, I get this traceback in Console.app:

Traceback (most recent call last):
  File "InstallLibraries.py", line 76, in <module>
  File "InstallLibraries.py", line 57, in downloadLib
  File "InstallLibraries.py", line 38, in downloadFile
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/urllib2.py", line 154, in urlopen
    return opener.open(url, data, timeout)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/urllib2.py", line 431, in open
    response = self._open(req, data)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/urllib2.py", line 449, in _open
    '_open', req)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/urllib2.py", line 409, in _call_chain
    result = func(*args)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/urllib2.py", line 1240, in https_open
    context=self._context)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/urllib2.py", line 1197,<…>

Glyphs Version 2.5.1 (1140), macOS Sierra 10.12.6 (16G1314)
For now, I solved it by manually installing vanilla into the Scripts folder.

I was experiencing the same problem (although first install of modules, not upgrade).

I traced the problem to a console message complaining about using old security protocols which I traced to python

    Glyphs[13714]: Traceback (most recent call last):
  File "InstallLibraries.py", line 76, in <module>
  File "InstallLibraries.py", line 57, in downloadLib
  File "InstallLibraries.py", line 38, in downloadFile
 ...........   REMOVED LINES   ............
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/urllib2.py", line 1197, in do_open
    raise URLError(err)
**URLError: <urlopen error [SSL: TLSV1_ALERT_PROTOCOL_VERSION] tlsv1 alert protocol version (_ssl.c:590)>**

As of May 1st, 2018 a new version of SSL is required (throughout the internet from what I understand). And apparently python is still using the old version…

After some research I found a solution to that problem by running:

pip install 'requests[security]'

However, that apparently only affected the python I installed with Homebrew. As the traceback shows Glyphs seems to be calling the python installed in the system folder; which don’t know how to modify- or if that’s even possible.

This is by no means my area of expertise here; I could be off-base here. And this may not really have anything to do with the problem… BUT it seems to me that to resolve this problem I’ve got to get Glyphs to use the Homebrew installed python (which now has its security upgraded) instead of the native System python. I don’t know if that is something I can “set” (and if so how to do it), or if this is a change which will require an update to Glyphs. OR, I’ve got perform the same upgrade on the system python- if possible. That is assuming, of course, that I’m not out in left field with this notion.

Does anyone a bit more knowledgeable have any thoughts on this? Ideas? Possible solutions?

BTW, I successfully installed Vanilla manually. Although, I’m not sure where to find the other modules that need to be installed and exactly how to install them.

Plus, the manual install seems like a bandaid, not a cure/solution to the issue.

If the root of this problem does turn out to be this SSL issue, then I’m assuming/hoping that should lead to a real fix.

However, I do have some reservations about this because the other thread referenced above pre-dates the SSL version deadline (although, I may have misunderstood or mixed up some information there- I was skimming over all the technical details in search of a practical solution).

Anyway, I apologize if I’ve dragged you guys down my empty rabbit hole!

Thanks for the research.

I have the same issue as otherviews. There’s no Vanilla folder in Scripts and the Scripts folder has rw permissions.

Can you check the macro window?

Speaking as a complete programming dumbfuck: Why do I need to update this vanilla thing and why does everything work fine anyway without doing so (besides getting me annoyed at every start up)?

1 Like

You get annoyed anyway because the old version takes 8 second to load. Did you try this: Manually installing vanilla module

1 Like

Sorry for the late reply. I get the following from the macro window —

<module ‘vanilla’ from ‘/Library/Python/2.7/site-packages/vanilla/init.py’>
[u’/Users/mattmcdonagh/Library/Application Support/Glyphs/Repositories/Red Arrow/RedArrow.glyphsReporter/Contents/Resources’, u’/Users/mattmcdonagh/Library/Application Support/Glyphs/Repositories/Fix Zero Handles/FixZeroHandles.glyphsFilter/Contents/Resources’, ‘/Applications/Glyphs.app/Contents/Scripts’, ‘/Users/mattmcdonagh/Library/Application Support/Glyphs/Scripts’, ‘/Library/Application Support/Glyphs/Scripts’, ‘/Network/Library/Application Support/Glyphs/Scripts’, ‘/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python27.zip’, ‘/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7’, ‘/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/plat-darwin’, ‘/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/plat-mac’, ‘/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/plat-mac/lib-scriptpackages’, ‘/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python’, ‘/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-tk’, ‘/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-old’, ‘/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload’, ‘/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/PyObjC’, ‘/Library/Python/2.7/site-packages’]

[edit] I followed your steps in the “Manually update Vanilla” thread — that seems to have done the trick.
Thanks Georg.

1 Like

I have the same issue. Tried both the suggestion in “Manually installing vanilla” and to install it following the install.txt from the downloaded repo. Message keeps popping up.

I am sorry, guys. I would expect this kind of error message in free software, not in commercial app costing 250 €.

Please fix it permanently.

I remove all files under the script folder. (/Volumes/LaCie/Users/xxx/Library/Application Support/Glyphs/Scripts). Restart Glyphs. Then with Glyphs/Preference/Addon/Modules/Install Modules, reinstalled the python modules required by Glyphs. After restarting Glyphs again, Glyphs would use the Vanilla module in the private folder rather than in the system wild folder, and thus doesn’t require the admin privilege to perform the update.

I fixed the automatic installation. So that should work with the next update.

1 Like

Hey Georg.

I am on Version 2.5.1 (1141) and the stupid message still persists. I have Vanilla installed.

When I import and print I get the following message:
<module ‘vanilla’ from ‘/Library/Python/2.7/site-packages/vanilla/init.pyc’>

It looks like the problem is persisting… I have the 2.5.2 installed but I still have the message everytime I open Glyphs.
I also tried to install it manually but it keeps doing it.
Do you have a solution?

Can you delete all instances of the vanilla module until importing throws an error? Then install it from Preferences > Addons. This should fix this. If not I would need to have a look at your system.

Do you mean deleting the Vanilla folder from the script folder ? I did it, but when I run “import vanilla
print vanilla”, I got <module ‘vanilla’ from ‘/Library/Python/2.7/site-packages/vanilla/init.py’>

Then delete the folder that is printed in the macro panel. Then restart glyphs and run the macro again.

Ok. Then it prints :
Traceback (most recent call last):
File “”, line 1, in
ImportError: No module named vanilla

So after this I tried again to instal it from Preferences but the problem persists.