Update vanilla library


#21

Sorry for the late reply. I get the following from the macro window —

<module ‘vanilla’ from ‘/Library/Python/2.7/site-packages/vanilla/init.py’>
[u’/Users/mattmcdonagh/Library/Application Support/Glyphs/Repositories/Red Arrow/RedArrow.glyphsReporter/Contents/Resources’, u’/Users/mattmcdonagh/Library/Application Support/Glyphs/Repositories/Fix Zero Handles/FixZeroHandles.glyphsFilter/Contents/Resources’, ‘/Applications/Glyphs.app/Contents/Scripts’, ‘/Users/mattmcdonagh/Library/Application Support/Glyphs/Scripts’, ‘/Library/Application Support/Glyphs/Scripts’, ‘/Network/Library/Application Support/Glyphs/Scripts’, ‘/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python27.zip’, ‘/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7’, ‘/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/plat-darwin’, ‘/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/plat-mac’, ‘/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/plat-mac/lib-scriptpackages’, ‘/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python’, ‘/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-tk’, ‘/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-old’, ‘/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload’, ‘/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/PyObjC’, ‘/Library/Python/2.7/site-packages’]

[edit] I followed your steps in the “Manually update Vanilla” thread — that seems to have done the trick.
Thanks Georg.


#22

I have the same issue. Tried both the suggestion in “Manually installing vanilla” and to install it following the install.txt from the downloaded repo. Message keeps popping up.


#23

I am sorry, guys. I would expect this kind of error message in free software, not in commercial app costing 250 €.

Please fix it permanently.


#24

I remove all files under the script folder. (/Volumes/LaCie/Users/xxx/Library/Application Support/Glyphs/Scripts). Restart Glyphs. Then with Glyphs/Preference/Addon/Modules/Install Modules, reinstalled the python modules required by Glyphs. After restarting Glyphs again, Glyphs would use the Vanilla module in the private folder rather than in the system wild folder, and thus doesn’t require the admin privilege to perform the update.


#25

I fixed the automatic installation. So that should work with the next update.


#26

Hey Georg.

I am on Version 2.5.1 (1141) and the stupid message still persists. I have Vanilla installed.

When I import and print I get the following message:
<module ‘vanilla’ from ‘/Library/Python/2.7/site-packages/vanilla/init.pyc’>


#27

It looks like the problem is persisting… I have the 2.5.2 installed but I still have the message everytime I open Glyphs.
I also tried to install it manually but it keeps doing it.
Do you have a solution?


#28

Can you delete all instances of the vanilla module until importing throws an error? Then install it from Preferences > Addons. This should fix this. If not I would need to have a look at your system.


#29

Do you mean deleting the Vanilla folder from the script folder ? I did it, but when I run “import vanilla
print vanilla”, I got <module ‘vanilla’ from ‘/Library/Python/2.7/site-packages/vanilla/init.py’>


#30

Then delete the folder that is printed in the macro panel. Then restart glyphs and run the macro again.


#31

Ok. Then it prints :
Traceback (most recent call last):
File “”, line 1, in
ImportError: No module named vanilla

So after this I tried again to instal it from Preferences but the problem persists.