Variable font export error message

Something went wrong while exporting: *** setObjectForKey: key cannot be nil

What does it mean?

Most likely an error that occurred while converting to TT and keeping outlines compatible at the same time.

  1. Have you tried the most recent beta?
  2. Can you narrow down which glyph triggers the error? We’d be very interested in it.

Most recent beta. Seems to happen to all my projects (from minimal to extended character sets).

Could you send me one of the .glyphs file?


I’ve got the same problem. If I try to export a variable font, the msg “*** setObjectForKey: key cannot be nil” appears. I tried to have only the basic set A-Z a-z, and I’ve revised all paths and are all compatibles.

I’m in Glyphs 2.5b (1099) but this happens many beta versions ago.


Please the .glyphs file to support [at] [this domain]. Thanks.

Done! Thanks! :slight_smile:

You need to add an Axes parameter in File > Font Info > Font:

ouch! My fault! I thought that the weight value work as a axes.

Thanks a lot!

It should still work if you don’t have the Axes defined (as you had expected). And now it does.


Hello. Ive got the same error exporting my variable font. My file currently has 52 masters and 3 axes. After hours trying to figure out what did i do wrong I came to see that I cant have the axes names shortcuts written in caps. Not sure if it is intentional, just wanted to ask. Thanks.
(error: *** -[__NSDictionaryM setObject:forKeyedSubscript:]: key cannot be nil )

52 masters?!

Non-standard axes are supposed to be all-caps, but the standard wdth, wght, etc. are lowercase.

The case of the axis tags shouldn’t matter. What version do you have?
Can you send us the file to have a look?