Variable font naming for italic face (conflict with regular)

To add more fodder to the mystery, I downloaded a trial version of Connect Fonts .
I used the “Clean Font caches…” process and restarted. No change to the duplicate problem in Font Book, or Word/Pages only showing the upright style names and the italic glyphs. However, if I activate the fonts in question using Connect Fonts, there were no errors and now all the styles names appear in Word (other than duplicates for Thin/ThinItalic) under a single typeface/family name (Dupuis VF). However, all the faces appear as Italic in the style dropdown even though the style names are correct.

If I apply each style to text it is presented accurately.

The style linking looks good if you followed the recommendation all the way through. Do the Font Info > Exports > Axes Coordinates > Weight match the appropriate Master weights?

Yes, the weight classes match the Weight precisely (100 through 900) for both upright and Italic. I contacted Extensis tech support regarding Connect Fonts and they provide additional info. The next step I’ll look at is adding PS names to each face that are different and see what happens. Here are some notes from Extensis:

Mac OS starting with Big Sur ( 11 ) and continuing with Ventura ( 13 ) is systematically locking down the System Fonts. Starting with 11, the operating system stopped allowing third party programs to deactivate system fonts on your machine. Now with MacOS 13, now the Supplemental folder appears to be a bit harder to get at as well.

Here are the locations of the System Fonts in MacOS:

  • SYSTEM: /System/Library/Fonts. - holds fonts essential for macOS to operate properly.
  • /System/Library/Fonts/Supplemental - holds fonts available for all macOS users.
  • LOCAL: /Library/Fonts - also holds fonts available for all macOS users; fonts installed by applications go here.
  • USER: ~/Library/Fonts - holds fonts available to the current macOS user; each user account has its own Fonts folder.

A font conflict is when a font has the same PostScript name as an activated font ( for instance a System Font as they are always activated ) and either won’t allow it to be activated or displays boxes and questions marks in place of the font. - see attached screenshot for an example is either present or activated. The error that you are getting in FontBook sounds a lot like a conflict although I have never heard of that specific error before.

Connect activates fonts at the system level and if these files are different, they will have a different font sense ID ( this is a number that we assign to the font ) - see screenshot. If your regular and italic versions of this font have different font sense ID’s then Connect is seeing a difference in the two flavors.

Just so we’re clear, your Font Info > Masters > Axes Coordinates > Weight = 100 for Thin Master?

I looked at both font attributes and the PS names are different for both (ID 4, 6). So I’m thinking it isn’t the PS naming.

When I look at the PS names and Font sense IDs in Connect fonts, they are different between faces. These are the two attributes Connect Fonts uses to differentiate between fonts. Since they are both different no conflict is found and they are both activated.

However, Font Book still sees a conflict and produces the odd behaviors in apps.

And, yet more mystery.

If I install Regular (with no problems) and then install Italic (duplicate, keep both) and I look in TextEdit or Word, then only the Italic style names are available.
If I look in Connect Fonts I see both faces, but regular is not activated. If I activate regular then I see all of the upright and italic faces in both TextEdit and Word. The only oddity is that the Regular face is lighter than the Extra Light. I’m thinking this has something to do with the font origin, maybe.

This is an article the Extensis sent me. It’s long, but has a lot of interesting info about the changes with Ventura. It appears that the olde clean font cache script may need some work. I’m going to experiment with the -removeuser option to see if that helps.

Font Management in Mac OS
For Monterey or later, use this command:

atsutil databases -removeUser

This removes all font cache files of the currently logged in user account.

  1. Restart your Mac in safe mode (different process for Intel vs Apple silicon)

I tried a different methodology this time. I ran this new terminal command and then did a safe mode boot:

sudo atsutil databases -remove

Instead of using Font Book to install the fonts I dragged them to ~/Library/Fonts

When I looked at them with TextEdit and Word, pretty much everything looked okay, except for these anomalies:

  1. In TextEdit there are no duplicate style names, but the Regular face is lighter than the Extra Light face
  2. In Word there are duplicate style names (two for Thin and Two for Thin Italic) and Italic is ‘Italic Italic’. However, when I apply styles they all work as expected. Regular is the right weight and Extra Light is the right weight.

What I’m thinking:

  1. Font Book may have some bugs
  2. There may be some new twists for naming that require more adjustments to get the font to work accurately for differing apps
  3. There may need to be a revision of the Font Cache Cleaning process to deal with changes to Ventura.

Please chime in with thoughts and feedback.

If that were the case I believe there would be more people reporting these issues. I still think you messed up the naming or the weights somewhere. I suspected the Master Axes Weight but you never answerd my question: Just so we’re clear, your Font Info > Masters > Axes Coordinates > Weight = 100 for Thin Master?

Check the other Masters > Axes Coordinates > Weight – they need to be the same as corresponding instance weights.

Sorry, I missed that post. Yes, I believe they are accurate. Here are screenshots. I’m assuming the instances wouldn’t work if these were set wrong.


I’m still confused by the font cache cleaning issues. I get an error when I run the

sudo atsutil databases -remove

command, and I’m told by Extensis that this command is no longer supported in Ventura. I’ve tried the revised command

atsutil databases -removeUser

followed by a safe mode restart. But don’t know if this actually working as the font behaviors don’t change.

In my experience, whenever I had similar problems with styles not being displayed correctly in apps, it was my wrong setting causing the error. It is really easy to add stuff that ends up causing problems with font naming. I think that @GeorgSeifert really made a perfect automatic naming system that covers all apps and versions. The less info you add, the better. If I were you, I would go through the @mekkablue naming tutorial again, make a new copy of the file and fill all the name fields from scratch. Remove anything that is not crucial.

I’m still wrapping my head around naming, and what might be important for my limited work.
When I look in FontTableViewer, at the italic face, I see that the ID 2 shows regular. From what I think I read, adding a VF Localized Style Name will set this value. However, in my setup is doesn’t seem to make a difference. I don’t know if I also need The Localized Family Name in conjunction. While I’m experimenting I removed the Localized Family Name because that seemed or override the Font Info>Font Family Name in Word/TextEdit.

Thanks for your feedback, it’s greatly appreciated. I’ll look at creating a stripped down file to test naming. The work I do is re-purposing OFL fonts for Native American language development. I do it free to help them out, so this isn’t a commercial endeavor and I know just enough to be dangerous. For this test I based it upon Libre Franklin. If I open the source .ttf in FontTableViewer it shows ID 2 as Italic. If I open the .ttf with Glyphs and export it, then ID 2 changes to Regular. In one of the original posts, @georgseifert advised me to just add a Variable Font Settings instance, add a Name of ‘Italic’ and that was all that was required. Maybe something in my source .ttf is complicating this.

I started over and created two faces, Roman and Italic. I kept it simple and have only 2 glyphs, ‘N’ and ‘a’. I created 2 masters, thin/bold and thin italic/bold italic. I created 3 instances thin/regular/bold and thin italic/regular italic/heavy italic. I tried with/without Variable Font Settings. I have no features. Metrics are all the same. I started with no additional naming parms and after exporting viewed the results with FontTableViewer and Font Book. As I saw issues I started adding custom parms (consulting the naming/variable docs) to deal with naming issues, and compared to working fonts in FTV. After a couple of 12 hour days I’m no closer to understanding what I’m doing wrong. I poured through the forum posts, but it appears that naming solutions have changed over time. I’ve cleaned the font cache so many times the Mac is starting to look shiny.
My fundamental issues, using different naming parms:

  1. Imports of the Roman/Italic faces produce ‘already exists’ errors. Although all 6 styles appear in FB, only the last import show in apps.
  2. There is no consistency of family name/style between Word/Pages/Mellel
  3. Frequently style names will either appear twice or appear once and be like ‘regular regular’ or ‘italic italic’

I have attached the two .glyphs faces I’ve been experimenting with. They’re probably no where configured correctly at this point as they’ve been changed dozens of times.
If a kind soul can take a quick peek at them, and let me know where I’m going wrong, I’d certainly appreciate it.
MyNewFont.glyphs (8.3 KB)

MyNewFont-Italilc.glyphs (6.8 KB)

To close out this thread, please refer to the thread listed below. VF TT fonts are not yet compatible with Ventura (as of 2022 11 22)

Variable Fonts on Ventura