Variable font question

Hi – I’m hoping there’s an obvious solution to this!

When you’re making a variable font, if you need to have the same number and allocation of nodes between each letter, how do you address the variation between roman and italic versions? For example, my font as a ‘hooked’ a in roman and a rounded a in italic – because it’s not consistent throughout the variants it’s showing up red.


That would be handled with bracket layers:

Perfect thanks, I knew there must be a simple answer!

Hi Georg – I’ve fallen at the first hurdle. I’ve selected the layer in question in edit view but I can’t find a way of copying it – when I try holding ctrl down it gives me other options, but not copy, and cmd-C doesn’t do anything. The plus sign just adds a new layer instance but not as a copy – could you point me in the right direction please? Thanks!

in the layer panel, select the layer and press the + button in the below the layer list.

Great thanks. The glyph in question is still showing red at the top – is that right?

Also, for some reason the preview of my font has disappeared on the home screen when I open the app, since I redrew all the glyphs as stroked outlines. I’m concerned that it’s a sign that the font still has problems. Sorry for all the questions! It’s such a complex font for a beginner to attempt!

No, as long as it shows the red sign, it is not set up correctly. It is explained here: (the text is not updated for Glyphs 3 but the basic idea is the same.)

Thank you – I worked out what I’d done wrong, and it’s showing as good now.

When I come to export it though, it’s now saying “Something went wrong when Removing Overlap in glyph: Acircumflex” – Acircumflex looks fine to me, I can’t see the problem with it. I tried unticking Remove Overlap and it exported the font, but with white intersections on some – but not all – letters. I’m not sure what I need to do to fix this.

This has been a bit of a painful process. My first font (also a contextual alternates one) exported without incident in an earlier version of Glyphs and seems to work fine, but this one isn’t going quietly! Thank you again for all your help.

What version of Glyphs do you have (I need the four digit number like 3062)?

It’s 3062

Can you send me the .glyphs file, then. I like to have a look and fix the issue.

Yes of course, what address should I use? Thanks!

To support at this domain.

First. I would make a second “Italic” axis instead of having the master in one line on the weight axis.
Then you need the bracket layer in all masters as Glyphs needs to build a new glyphs that it can switch, too.

Thank you Georg. How do I add another axis on the Master panel? According to the tutorial on the Glyphs website there should be a + on the “Axes Coordinates” line, but there isn’t one in the app (I’m running the most up to date cutting edge version). I’m assuming it’s changed since the tutorial was released.

You add axes in the font settings.

Ah! Thank you both, I was stupidly looking in the Masters tab

No worries, I was looking for it on the Master tab too until I was told not to :slight_smile:

1 Like

This font really isn’t going quietly. I managed to export it as an otf (just the regular though, no italic, bold or bold italic), but it did something funny when I tried using it in Illustrator.

This is the font in Glyphs: