Variable fonts, Component & Anchors issue

Hey, a small update to this. I tried in Glyphs 3 now, still the same problem is there. Would be really helpful if this could be fixed — it’s quite hard to export a fully functional Variable font with Virtual masters as it is now. Crossing my fingers.

Did you send me a sample file?

I don’t think so, I can do it now. What address?

Update: Yes, I did last time. I can send you a new one, to support at this domain

(EDIT: no functional e-mail addresses spelled out in the publicly accessible forum please.—mekkablue)

Any news on this? :slight_smile:

I’m looking at it ASAP.

1 Like

Any news on this now? It would be SO great if this could be fixed, it feels it’s already there somehow… since the instances are producing a good result.

I think I have good news.

1 Like


Do you know when? :nerd_face::upside_down_face:

It is in Glyphs 3.0.2. Will not backport it to Glyphs 2.

This is freshly generated Variable font in Glyphs 3.0.2. Typed in Illustrator.

This is how the preview looks in Glyphs with ”Variable font viewer”

So the output Variable font does not work on my end. But generating instances do, and also inside Glyphs with this preview plugin.

You want the file?

I see the problem. But don’t have a solution right away. For now, add the brace layers in the components, too. This is quite a different problem than the bracket layer (that I’ve fixed).
I’ll think about this.

1 Like

Aha, OK. I have quite many layers, better get to it, haha!

Or is there @mekkablue script for this other than the ”insert layers” I found?

Something like ”Insert-brace-layers-to-component-glyphs-based-on-key-glyph”?

If not I’ll ask maestro @Erik_M to write one :slight_smile:

Myself, I will NEVER learn to code. To old and stubborn for that, haha.

The Composite Variabler in the mekkablue scripts could do the layer insertion. Buti guess it’s gonna be fixed soon.

It says in the plugin it’s for Bracket layers. This problem is with Brace layers and nothing happens when I use the plugin. It has taken almost 3 years so far to try to get it fixed, but hope it can be fixed soon :pray:t3:


It was written in Glyphs 3 Build 3069 ”Fix brace layers in OTVar export”. This did not fix this issue, so you know. Or was this something else?

Can you send me a sample file?

I did a couple of weeks back. I resent it just now.

The videos don’t work anymore. But as far as I see, the exported fonts work as expected:

That screen shot can’t show that, but if you max the ”Terminals” axis and show me a screen shot we’ll know.