Variable Fonts on Ventura 13.0.1

I’ve read all of the tutorials on VF, Masters, Naming, etc many times. I’ve reviewed most of the forum posts relating to VF and naming, along with your suggestions. I’ve tried the various solutions with not much luck (with the understanding there may be things I’m misunderstanding or getting wrong.) My hair was already thinning before this started.

These problems seem to impact VF TT .ttfs where there is a single family name and the Regular and Italic faces are in 2 different VF TT .ttf files. However, I ran at test where I put both Regular and Italic VFs in the same Glyphs file and had similar problems, although my configuration may be suspect. I reviewed forum posts that seemed to imply having separate .ttfs was the preferred methodology.

I’ve done extensive testing with 4 different Macs on Monterey/Ventura and Intel/Apple silicon

  1. VF TT .ttfs on Monterey 12.6.1 Intel silicon
  2. VF TT .ttfs on Monterey 12.6.1 Intel that are subsequently upgraded to Ventura 13.0.1
  3. VF TT .ttfs on Ventura 13.0.1 Intel silicon
  4. VF TT .ttfs on Ventura 13.0.1 Apple silicon

What I’ve found (understanding that there might be something really wrong with my workstations that I haven’t yet found):

  1. VF TT .ttfs on Monterey 12.6.1 install fine with Font Book and work okay in an app like TextEdit (other than that font does not appear in the default font dropdown, you need to open the font dialog and switch from English to All Fonts to see the font)
  2. VF TT .ttfs that are installed on Monterey 12.6.1, and then the workstation is upgraded to Ventura 13.0.1 seem to work fine in apps. However, as soon as they are removed and re-installed the problems begin (and, yes, I’m doing a revised font cache clean that I think works with Ventura.)
  3. VF TT .ttfs on existing Ventura run into issues with installation using Font Book, drag/drop to ~/Library/Fonts or with TypeFace Pro. In addition, those installation issues create downstream problems for apps. And, yes, I’m running a Ventura compliant font cache clean at each instance.

I tried both Glyphs VF TT .ttfs, FontLab VF TT .ttfs and OFL VF TT .ttfs I’ve downloaded from They all seem to have issues, for me, with Ventura both for installation and use.

Has anyone else had problems with new installs of VF TT .ttfs on Ventura?

Yes. Completely ignored all the way with Font Book or Font Book claiming it could not open the VF. Ventura has some serious font bugs.

I submitted a Developer Feedback report to Apple.

1 Like