Various things I wanted to get off my chest

is it me or has Glyphs got worse? I have been using it for about 7 years but since v3, I have all sorts of there was a problem with undo and regularly failing to remember something I copied in another window/glyph/layer. and yes, I have tried running without plugins, and no, I can’t make a movie of it, because it doesn’t happen with any predictability. furthermore, the v3 manual has been coming soon for half a year, I think it only fair that you excise the word soon from the description

I do not doubt that that is your experience, but stating more concrete issues is more constructive.

Do you recall the last time undo did not work for you? There is currently an open issue regarding undo, maybe your issues with undo match that ones described there? That could help to reproduce it.

Do you mean Glyphs does not remember the copied value and thus you cannot pasted onto a layer in Edit View? Or from another application into Glyphs?

It’s difficult to give a good estimate for how long something will take to write, especially now where Glyphs 3 both added a lot of new features and also extended many existing features. Also, the type design landscape is quite different now since the last major revision of the handbook (e.g., variables fonts are now a thing and that affect almost every part of the handbook).

In the meantime, the tutorials and release announcements cover most of the new topics. Relevant tutorials:

Version announcements:

1 Like

the copy/pasting is all happening within glyphs. I have worked this way for 30 years = FontStudio/FontLab/Glyphs 1 and 2 and never had any trouble until glyphs 3

Are you using a clipboard manager? An app that keeps a history of your recently copied items?

what I omitted to mention in my original post is that v 3 is crashing a lot. previous versions were always very stable

yes, but turned off for glyphs

Is the copy/paste loss over a long time or when pasting directly after copying? And what are you pasting that is getting lost? Entire glyphs, paths, components, or single nodes?

Can you try to start while holding down Option and Shift (to disable plugins)? This might help with the stability.

I’ve already deleted all plug-ins, isn’t that the same thing?

crashing several times a day now, I’ve sent the reports

What exact version are you using (the four digit number like 3091)?
And did you add a note to the crash reporter (your name or a reference to this thread would be useful).


Can you update to the latest cutting edge version (activate it in Preferences > Updates)?