VarOT, kerning is not working

I am testing a variable font in web/Illustrator and the kerning is only working at the lighter extreme, while sliding to heavier weights kerning disappear. In my file, the heavier weight is kerned. Why is this? is there any tweak I have to take care of?

Which Glyphs app version?

Version 2.5.1 (1141)

  1. Try the latest cutting edge version.
  2. Is there a difference between AI and the web browsers? The AI implementation is still buggy and that may show in broken distances.
  3. Where in the designspace are your masters? And how many do you have?

tried latest cutting edge, same. Web/Illus is the same, I’ve noticed that some kerning pais works well and others not. :neutral_face:

To be honest, I don’t know what a designspace is, but I have 3 different axes and 8 masters

The axes span open a designspace. The position in the designspace are the coordinates of the masters.

  1. Are the masters arranged in a cube?
  2. You probably do not need all 8 masters for the variable font. But that also depends on the design.

Yes, 8 masters is due the design. The axes are Weight, Slant and Height. check the screenshot.

  1. If the Axis Location parameter has the same value as the Axes coordinates, you can safely get rid of the parameter.

  2. Are all light weights Weight=45? All heavy weights have the same axis coordinate? Same with Slant (all upright =0, all slanted ones with the same value) and Height axes?

  3. I would try to see if you could do without the Bold Italic. And possible also without both Small Italics.

Could you send me the .glyphs file and the document that you used for testing?

It’s weird, the only kern pair isn’t working well is ij and i is not a component of dotless i

  1. Ah ok. 2. Yes, light 45, heaviest 184. All are good set up. 3. Yes, I will start debugging like that.

Found the issue.

If I close the lock in here, the kerning works well while interpolating. so I can’t make exeptions like that?

It might work if you have exceptions in all masters.

ah, right. Ok, problem solved then. Thanks!