Version 2.5.2 (1171)


#1

Is this beta release compatible with Mac os High Sierra

Regards


#2

I am running it on High Sierra. So, yes.


#3

It should be working fine on 10.9 to 10.14.


#4

Thank you both for the reply running it on macOS High Sierra 10.13.4


#5

You should install the latest security updates from Apple (10.13.6)


#6

I currently need to run 10.13.4 so what security updates does Glyphs require.

Regards


#7

Glyphs does not require it but it is not a good idea to run a system that is not fully updated. But you seem to have your reasons. Just be careful then.