Version 2.6.3 (1270) very slow to generate fonts

Hi there,

When I try to generate a whole family with the latest Version 2.6.3 (1270) the process is way much longer than with older versions. It also crashes when I try to run certain scripts like ‘Select same color’ and ‘Select Glyphs with Outline Errors’

Any idea?


Cannot reproduce. Can you send me the file that takes long?

Sure. File sent.

I had a look at the file. Overlap removal is what takes the most time, then PS hinting. But only the first time around. Once the Temp folder is established, export takes about 2 seconds on my old MacBook Air (Mojave).

For quicker test exports, consider disabling overlap removal and/or hinting, depending on what you are testing for at the moment. What may also help is emptying out the Temp folder, and reexporting slowly once, and after that first initial export, it should be fast again.

Plug-ins may interfere as well. Restart the app with Opt and Shift held down, then see if exports faster.

Plus, there may (temporarily) be another (unrelated) process taking up system resources. Consider top -u in terminal or Activity Monitor to check if there is sucha process taking up resources.

You are missing the point: why 2.5.2 version generates the fonts quickly and 2.6.3 takes ages? The setup is the same and the open processes the same, but 2.5.2 works well and 2.6.3 not with the same file. In my computer it takes ages to generate every time, not just the first time.

I tried in 2.6.3 (1270), and it was as quick as I described above.

Does the delay occur with the latest beta as well? Go to Glyphs > Preferences > Updates, activate both checkboxes and press the Update button. (Edit: you mentioned 1270 in the first post already, was focused on 2.6.1 now.)

To track down the source of the problem:

  • Perhaps redownload the app and reupdate.
  • Try in a different user on the same machine.
  • You tried emptying the Temp folder?

Sorry, the problem is in 2.6.3 (1270) and it’s clearly not due to any file related thing. I tried with other files and it’s always the same, it’s take too much time to generate the fonts.

How long does it take exactly?

It could be related to the setup in your Mac user. How long does it take in a different user?

Perhaps there’s a problem related to the system version. But I can’t verify that. I have no access to a different Mac now.

It takes 3 minutes to generate the family. That’s a lot and considerably longer to previous Glyphs versions running the same file.

It took 20 seconds on my iMac from 2014. So there is something going on. Can you start Glyphs without plugins (hold Opt+Shift)?

Opt / Alt + Shift? I get the same results.

Hold down Opt+Shift when you start the app. Make sure that there are no plugins loaded (e.g. the reporter list should be much shorter). The export again.

Same thing. Still spinning.