Weird Sans-Serif Font when I Export

When I export my italic serif, a random sans-serif (looks like Helvetica to me!) appears in InDesign? I export all of my fonts to the Adobe Fonts folder and have tried renaming the Family and Font names as well as the “Clean Font Cache” script to no avail?

I finally gave up and installed it in Font Book (which I know is wrong) and it worked. Anyway that I can go back to the efficiency of Adobe Fonts?

Sorry to add another question instead of an answer to the problem but can someone explain to me why installing a font in the font book (Schriftsammlung?) is wrong?

It is wrong while working on it. The system caches a lot of stuff and if you install a new version of the font, you never know what state you are looking at. There are some tricks to circumvent this but in general it should be avoided to not waste time looking at outdated font data.

1 Like
  1. Yes, the German name of Font Book app is Schriftsammlung.
  2. Because of the font caching that happens when a font is installed in ~/Library/Fonts or /Library/Fonts. For more details, consider a glance at the Eliminating Font Cache Problems tutorial.
1 Like

I recommend to:

  • verify writing permissions in that folder.
  • double check the files actually get written as expected (clean out the folder, export, and analyse the OTFs.
  • verify it really is /Library/Applications Support/Adobe/Fonts/ you are writing into (and not one of the similar folders in other locations).
  • restart the Mac with the Shift key held down (until it says ‘Safe Mode’), and restart again without the Shift key. This should clear all kinds of caches.
  • try in a fresh user you set up in System Preferences > Users. If it works there, then it is a user-specific setting that is in the way.

I usually use /Library/Applications Support/Adobe/Fonts/ as the user folder sometimes doesn’t work for me. So you might need to experiment a little.

True, me too actually. I corrected this in my posting above.

Thank you for all of the advice. I’ve tried all of them and still the weird sans-serif characters show up.

Not sure what to do next?

Perhaps I can help you if you answer to the steps I outlined in the above posting. E.g. did you verify the font file actually gets exported?

2 posts were split to a new topic: Glyph appears empty in Font View

Closing this thread because it is going off-topic. I’ll move the new question to a new topic (so it can be found by people looking for a solution to a similar problem).