Why does OffsetCurve require a RemoveOverlap custom parameter?

I was using OffsetCurve for one of my instances. On export I checked the box to remove overlap, but realized it wasn’t working. I was seeing white triangles in the crotches of of some letters. In Illustrator I converted to outlines and found that the overlaps hadn’t been removed. I created a custom parameter filter to RemoveOverlap which worked. Is this expected behavior? Why doesn’t the export checkbox work on the OffsetCurve filter? I’m on 1197. I tried 1192 and got similar behavior. That this point I’m fine creating the extra filter. I’m just curious.

The filter kicks in after the overlap has been removed. And it can create new overlaps of course.


When RemoveOverlap appears dimmed … does it mean a problem in definition or is it inapplicable at that position ?

The name must be Filter And the value must be RemoveOverlap

1 Like