Width of component letters

If I create letters which consists of two components, the width of the character will automatically take the space of one of the components. But on what grounds does that happen? I don’t get the logic.

I have a large set of “circled characters” like uni24BE (circled I).
Since one of the recent updates some of those glyphs now have the width of that Latin letter, not the box around them. How do I change that without decomposing the composites?

This is a bug. Will fix this.

Now you have to disable the automatic alignment for both components (in the context menu) and use metrics keys to align the metrics.

What character did you use circle?