Windows style-linking?


#1

I have a font family with more styles that the basic 4 styles. I’m afraid the other styles will not be available in Windows apps.
Can I style-link these styles to the main family on windows or should i split them to sub families like condensed etc.?

Thin
Black
Extra-Black
Condensed
Condensed-Bold
Condensed-Black

Thanks


#2

They will be available. Just style-link all italics to their respective uprights.


#3

Since I have no italics in this family, will all other styles be visible? how will the user get to select the condensed or extra black?


#4

Only style link Bold to the the Regular in that case. The other fonts will appear as separate entries in the font menu.


#5

Thanks - works just fine!


#6

How can I force Windows to show the bold in the font menu? In e.g. MS Word I want to see “Myfont Light”, “Myfont Regular”, Myfont Medium" and “Myfont Bold” in the font menu. I deliberately don’t want to link the Bold to the Regular by style linking. The family has the four styles Light, Regular, Medium and Bold.

Up to now, I only managed to see the Light, Regular and Medium in the font menu and the Bold has to be choosen with the Bold button applied to the Regular.

Thanks a lot in advance!


#7

You just don’t check the checkbox at “is Bold”.


#8

Think twice, though. Windows users usually expect the Bold style to be accessed through the B button (or the shortcut, Ctrl-B in English), and not show up in the menu. Same is true for Italic and Bold Italic.


#9

That was the first thing I tried. But it doesn’t work, I still get just Light, Regular and Medium in the Font Menu – no Bold. And yes, I deleted the Font cache, reinstalled the fonts (also tried with a new Family name) and restarted the computer. Is there eventually something more I can do?


#10

Thanks – I am aware of that.


#11

Then something else must have gone wrong. I just tried again, the Bold bit is the only thing that keeps the Bold out of the menu. If you want to make sure, you can send me your .glyphs file.


#12

No, Windows Family name and Menu Name must contain the word “Bold” as well, Glyphs does that automatically when the bit is off?


#13

Glyphs builds the RIBBI families automatically in the Windows naming if you set the bit (I should have said, ‘click the checkbox’) in the Glyphs UI.


#14

Problem solved. The field after the Bold checkbox has to be empty (I still had “Regular” filled in, which makes the difference, even if the Bold checkbox is unchecked):


Thank you for your help!