Windows won't install fonts exported from G3

This is happening with any typefaces I’ve designed and exported from Glyphs 3 lately:

Any help would be appreciated. I’ll investigate in the meantime. Thank you!

Update: TTF files will install, but not OTF.

Can you send me that .otf?

Done. Thanks Georg!

Update: font exported from Glyphs 2 will install on Windows with no complaints from the OS.

Can you send that file as well?


I’ve looked into this some more. Two of my typefaces still won’t load on Windows 10 after being exported from G3, but I just tried two different typefaces, and they work just fine.

The two that are misbehaving are monospaced fonts. I’ve tried exporting from G3 with isFixedPitch both on and off, but no luck in either case. I’ve tried removing a bunch of characters, including Vietnamese, European, and Japanese glyphs, but no luck. I’ve removed all my special programming ligatures and custom Powerline glyphs, but no luck.

So it seems I can use Glyphs 3 for some of my work, but for these two monospaced typefaces I have to use Glyphs 2. I know it’s not just me, because when I sent out a recent update, many of my Windows-using customers reached out with the same issue.

I figured it out. It’s this lone glyph here: ellipsis.vert.

Screen Shot 2021-05-04 at 6.54.55 PM Screen Shot 2021-05-04 at 6.54.43 PM

I don’t know yet if the issue is the glyph itself, being a “.vert”, or if it’s something wrong with my construction of the glyph. However, I do know that G2’s exported version works on Windows, even with this glyph in place.

Anyway, if I delete this glyph and export from G3, the resulting OTF files work in Windows 10.

Edit: further testing shows that the presence of this glyph at all causes the OTFs to not work or install in Windows. Even if the glyph itself is empty, if it’s present, Windows throws up the error shown in the first post.

Thanks for your research. .vert glyphs should trigger the respective vertical substitution features. Perhaps their presence confuses the installation mechanism.

1 Like

Thanks! Is there something that changed between G2 and G3 with regards to .vert? The G2-exported font files install in Windows just fine. It’s the G3-exported set that won’t work with the .vert glyph still in place.

Can you send both .otf from the same file?

Same problem found. I can’t install my font on Windows if it contains .vert. Any solutions? Thanks!