A problem occurred

text: ‘AG
AV’ (__NSCFString), length: 20, string: ‘NT{
}’ (NSConcreteAttributedString), length: 2, range: {21, 0}


NSMutableRLEArray insertObject:range:: Out of bounds

“3 Foundation 0x00007fff30231563 -[NSMutableRLEArray insertObject:range:] + 151”,
“4 Foundation 0x00007fff302320df -[NSConcreteMutableAttributedString replaceCharactersInRange:withAttributedString:] + 242”,
“5 Glyphs Mini 0x000000010fe1548f Glyphs Mini + 234639”,
“6 AppKit 0x00007fff2b7648c5 -[NSTextInputContext(NSInputContext_WithCompletion) insertText:replacementRange:completionHandler:] + 75”,
“7 AppKit 0x00007fff2bff65f5 __55-[NSTextInputContext handleTSMEvent:completionHandler:]_block_invoke_2.385 + 109”,
“8 AppKit 0x00007fff2b764874 -[NSTextInputContext do_HandleTSMEvent_insertFixLenTextLoop:whileCondition:dispatchWorkEach:afterEachInsertText:continuation:] + 110”,
“9 AppKit 0x00007fff2bff456d -[NSTextInputContext tryHandleTSMEvent_insertFixLenText_withContext:dispatchCondition:setupForDispatch:nestedWorkaroundCondition:nestedWorkaroundDispatchWork:loopCondition:dispatchWorkEach:afterEachInsertText:continuation:] + 320”

What did you do to make that happen?

I tried to make arrows accesible through making them typeable with a calt-Feature.
(Does it matter if liga or calt?)
By activating the feature and typing the cobinations this message came up.

text: ‘–> <– ^||’ (__NSCFString), length: 9, string: ‘^{
}’ (NSConcreteAttributedString), length: 1, range: {10, 0}


NSMutableRLEArray insertObject:range:: Out of bounds

“3 Foundation 0x00007fffada3f733 -[NSMutableRLEArray insertObject:range:] + 151”,
“4 Foundation 0x00007fffada402ca -[NSConcreteMutableAttributedString replaceCharactersInRange:withAttributedString:] + 223”,
“5 Glyphs 0x000000010f4d60f0 Glyphs + 327920”,
“6 AppKit 0x00007fffa9c92c0b -[NSTextInputContext(NSInputContext_WithCompletion) insertText:replacementRange:completionHandler:] + 79”,
“7 AppKit 0x00007fffaa4cbdf3 __55-[NSTextInputContext handleTSMEvent:completionHandler:]_block_invoke_2.379 + 108”,
“8 AppKit 0x00007fffa9c92bb4 -[NSTextInputContext do_HandleTSMEvent_insertFixLenTextLoop:whileCondition:dispatchWorkEach:afterEachInsertText:continuation:] + 111”,
“9 AppKit 0x00007fffaa4c9c98 -[NSTextInputContext tryHandleTSMEvent_insertFixLenText_withContext:dispatchCondition:setupForDispatch:nestedWorkaroundCondition:nestedWorkaroundDispatchWork:loopCondition:dispatchWorkEach:afterEachInsertText:continuation:] + 387”

Can you reproduce it? If so, please send me the .glyphs file please to support (at) (this website without www).

dlig if at all. Should be a conscious decision of the user. But it is the question if this should be solved in the font at all. Better probably to add an autocomplete text in System Preferences > Keyboard > Text.

Danke Rainer!

Mail mit der Datei ist raus.

For reference:

The problem was that the feature code used a glyph that is connected to a character which is used as a dead key for accents.

What happened precisely: asciicircum is used in the feature code, which is typed with the circumflex key on the keyboard. The circumflex key is a so-called dead key though, meaning after it is typed, it waits for the base letter to combine into a diacritic letter. E.g. you would type circumflexe → and you receive ê. But after typing the circumflex key in this case, a vertical bar was typed, and that messed up the character count, and therefore you got an Out of bounds error.