Accent Cloud not showing

The accent cloud is not showing in the contextual anchors or the smart glyphs.

can you send me a screenshot.

1 Like

You mean there is no cloud on the *bottom… anchor? I’ll have a look.

Exactly. *anchors do not show any cloud, and any anchor do not have a cloud in _smart glyphs

The mark clouds are defined in the glyph data for each glyph. So smart glyphs dont have and so can’t show clouds. What kind of smart glyphs do you have?

They are the Arabic letters that can be extended with a kashida or their cups can be expanded.

I see.

There are two options how to move this. Either add font info to the _smart glyphs. Or make “normal” glyphs (that have the info already) smart. I choose the second option. If you have a glyph like “ain-ar.init.lenght”, you can manually add a subCatategory “Smart”.

There is already a hack to turn every glyph into a smart glyph. But having a slightly better way doesn’t hurt.

So with the next version, you can rename the smart glyphs to use this.