Add glyphs and Make Component glyph not working

Either way, Add glyphs and Make Component glyph are not working.

I tried it before and after deleting (needed) glyphs. In Edit and Font view.

Built 702, OS 10.9.5

We changed the composition rules for accented glyphs recently. now it uses the combining marks (acutecomb instead of acute). The easies fix is to add the ‘comb’ suffix to all your marks (Find and replace: empty Search, and ‘comb’ in Replace will add the ‘comb’ to the name.


A few days away of the forum and the world changes :slight_smile:

Does it apply to all languages ?

It is mostly a Latin problem. Most other scripts have used combining marks from the start. You can check the decompositions yourself in Window > Glyph Info, search for the composite glyph, and its decomposition is displayed in the rightmost column (enlarge the window to the right maybe).

So I should go thru my old files and change the names of all the diacritics? I used to have both acute and acutecomb; should I now have only acutecomb?

How do I handle what used to be .case, .sc, and .narrow marks? Right now the command is sticking the ‘comb’ marks on everything, even if the base glyph has the correct suffix.


For those projects I’m continuing to work on, I renamed marks like acute to acutecomb. I kept acute and such around using the *comb glyphs as components. So, breve would be made using a component of brevecomb. I still wanted those glyphs with their unicode values (e.g., acute/uni00B4) in those projects.

Continue to use your .case, .sc, and .narrow marks. So, have, for example.

I’d want to test using a regex in the find & replace before suggesting an option there. A quick experiment shows you might be able to use:

Search pattern: ^([^.\n]+)
Replace pattern: \1comb

That would assume you want to add comb to the end or before the first period. I wouldn’t have expected to need the ‘\n’ in the class, but the ‘\1’ reference seemed to include it upon a quick test. That search pattern says to start at the beginning (^), match 1 or more (+) characters up to a period or newline and add comb to the end of that match.

Note that if you already have an acutecomb selected, the above will rename it to acutecombcomb.

I haven’t tested to see if Glyphs makes other assumptions.

No, you need both. If you have both already, you’re good already.

For future projects, it is recommendable to have the …comb accents first, then generate the legacy accents (without …comb). This will create them with the …comb accents as components.

Thanks, Erich, Jeff, and Georg!