Add the glyphs on keyboard

Newby in the matter, I can’t find out how the attribution of the designed glyphs gets fixed on the keyboard.
How do I choose the attribution of a drawn symbol to a specific key?
Thanks for any hint and help.
Have a nice day.

OK folks,
After a little time fumbling in Glyphs Mini with windows, I found the way to affect my symbols to the keyboard by naming those from the list of standard name codes.

1 Like

The best idea is to simply pick a fitting glyph name from the sidebar on the left (Categories, Languages), or from Window > Glyph Info, where you can even search for glyph names. Glyph names are usually linked to certain Unicode values, e.g., uppercase AU+0041. Unicode values are what is actually stored when you save a text file.

The relationship between a Unicode value and a specific key on the keyboard is not organised inside the font, but through a so-called ‘keyboard layout’. You can choose an existing one in System Preferences > Keyboard > Input Sources, or make your own with an app like Ukelele.

Want to know more? Read this tutorial:

Thank you very much for your kind attention and answer.
Yes, I found the extra window with the listed names and Unicode values.
The new glyphs also have to be asked for under the “Font” area.
Actually, I was making it more complicated than it is. Pasting stuff on the basic A,B,C table makes it all very easy and confirm to the keyboard…

…Yet I have another problem: exporting the new font won’t have the name i’ve been giving.
It will only be named “New Font” and refuses to appear otherwise in my Font Book.
The font book finder recognizes the given name, but the active font still remains “New Font” when scrolling down the fonts list!
I’m puzzled…

This is probably a font cache problem. Read this please:

I recommend using the Adobe Fonts folder instead:

You need to set the Family and Style name in Font info.

Seams to be OK in the font info too… :sweat_smile:

Here is how it looks like:

Then you have a font cache problem as mentioned above. Please follow the instructions given in the tutorials.

:thinking: Followed the cache erasing procedure, but when adding the “Tarls18b.otf” font it still shows up as “New Font”!
:sweat_smile: + :scream:

I’m missing that point, or don’t understand the meaning of it: How do I make sure to do both? And is it to be seen at the same place?
Thanks in advance for your patience.

But the origine of the trouble could be elsewhere…

The “New Font” is defined in Font Info > Font. Click the “i” button in the toolbar and then the dust tab in the top left.

What you changed is the file name of the .glyphs file. You need to change the Family name of the font.

1 Like

Problem is: the name appears right in the library/fonts liste. It is only when using the font in ANY other app that it shows up as “New Font” as its name… :sweat_smile:
And I already erased 4 times the caches​:muscle:t2::face_with_thermometer::weary:

P.S. I re.tried it all over: whatever I do the “Tarls18” becomes “New Font” (as family name + courant* - *but thats what it is).
Is it because of the “mini” free version, with a salvation by buying the “mini” license?
This could be a way to make sure a user can’t create more than 1 font without a paid license. :thinking::man_technologist:t2::stuck_out_tongue_winking_eye:

Set the font family name in Font Info (cmd-I).

What you named was the file name of the .glyphs file, the font name in font info is unaffected by that.

And again, do not install the font for testing. Use the Adobe Fonts folder instead:

Or use TextPreview (free app in the tools section of this website).

I’ve quitted Adobe’s since few years now… :innocent:

Then try TextPreview. Export your fonts into a folder, and point TextPreview > Preferences to that folder.

Whatever you do, do not install an unfinished font.

Thanks for the hint… but, in TextPreview the fonts name ALSO changes into “New Font” instead of keeping its real one!

Amazing, isn’t it?

I think I’ll use it as is, since I only need this one for my next book. In the worst case, if I create once another font with Glyphs, I’ll have several “New Font” each in a separate folder.

@alex53 Did you try to change the ‘Family Name’ in the Font Info window?

Press CMD+I to open the Font Info window. Under the font-tab you can set the Family Name. The default name will always be ‘New Font’. Change that and it should work.

1 Like