Adobe cache problem

Since installing Glyphs3 ánd OS11.0.1 I have cache issues.
Like I always do I export the .otf to the folder Library > Application Support > Adobe > Fonts. But I have to quit InDesign and Photoshop and reopen the document to show the newest font version.

I also tried the “Test Install” function in Glyphs3 (after deleting al temp font files everywhere). Same story.

And last but not least I tried this script /hagenburger/glyphs-export-and-install but this doesn’t do anything.

I hope there is still a way to get the newest export of the font instantly in Adobe apps. Thanks a lot!

Did you verify the folder exists, is called Fonts (no trailing spaces, case-sensitive), and the font actually gets written into the folder?

Which exact version of InDesign? The 2021 ones?

It is possible that Adobe’s access to the Library is limited in macOS 11, or that Adobe apps need an extra permission in System Preferences > Security > Folder/Disk Access.

Thanks for the help! Yes, the font files are written in the fonts folder when exported. I am up to date with the latest CC applications. Folder/Disk Access preferences looks okay.

For example: I quit InDesign, export my font and only use the Bold in InDesign. Then I edit my font, export again and the bold is unchanged in InDesign. The Light and Regular are changed like it should, because I didn’t use it in InDesign already.

And if you switch from the Bold to Regular, then back to Bold again? (without a restart of the app)

In this example the bold is the old version that didn’t change, the regular is the newest version (I deleted the inner circle of the % to make the cache thing visible).

Somehow it works now, I don’t have cache issues since I updated to 3.0.1 (3034)!