Adobe Fonts folder not working in Big Sur


In Indesign, I always need to restart the app to see the updated font. I have Big Sur 11.0.1 and Indesign 16.0.1. Am I missing something? I have tried the two different paths, the Adobe one and the Test Install one.

The Adobe Fonts Folder works as expected for me in Adobe InDesign CC. No need to restart InDesign. Which version of InD do you have? And which exact Fonts folder path?

I have Indesign CC, version 16.0.1, I am actually up to date. With Glyphs as well, version 3.0.2. My Fonts folder path is: Macintosh HD>Library>Application Support>Adobe>Fonts

Then you do not need to restart InDesign, unless there is an incompatibility of Adobe’s feature with Big Sur. But that would be the first time I’d hear about it.

The only thing that can interfere is a systemwide install (or test install) of a font with the same name.

When you created the folder, was InDesign running? That is when you have to restart once, because InDesign only keeps track of the Fonts folder contents if the folder existed at app startup already.

(Moved the posts to a new thread, they were off-topic in the original thread.)

I also have an issue on Mojave. When exporting updated fonts to Adobe fonts, coming back to Indesign the text disappears completely, or glyphs take width of zero (so all letters are one upon another). I need to restart Indesign to see my text pages correctly again.

And me too I see no change on Indesign after exporting.
I need to restart Indesign each time to see changes.

I once had an issue where it took a moment. Or switching to another app and back again.

You can delete InD caches as well. I believe you need to hold ctrl+opt+Cmd (+shift?) during startup until a dialog appears.

Did it already. doesn’t work it this case.
Deleting cache doesn’t help if I have to restart InD anyway :smiley:

Good news! It works now since I updated Big Sur, from 11.0.1 to 11.1.

1 Like

I’ve deleted all MacOS caches using Onyx app.
Then I’ve tested again and I noticed InD updates the fonts, as expected, only if no “Test Install” was made before. After I exported once as “Test Install” InD bugs when I export again in the Adobe Fonts folder.

1 Like

That is interesting.
If you Test Install, Indesign will keep using it or at least the conflict will mess things up. To get rid of the Test Install, you need to quit Glyphs (I think).

You need to restart the OS to flush the test install. About InD, the strange thing is “test install only” is not recognized (missing font warning) but it interferes with the fonts exported to adobe/fonts. Maybe test install should have some hidden naming to make Adobe apps to ignore it, or at least to think it’s another fontface

Logging out and back in should do. But o cannot test in Big Sur.

I made an app that deactivates test-installed fonts. This may be useful to you.
Deactivate Test-Installed Fonts
To use this, just boot.


this is awesome, thanks!

@mekkablue this app should be linked to in the resources page, super useful!

1 Like