After saving, the combine is broken

Hi.

I’m currently using the latest version of Glyphs 3 on my m1 MacBook.

Create new glyphs, combine alphabets and signs, and save them.
If you open the saved file again,
Only letters that combine “ogonek” and “cedilla” are broken.

I tried the automatic glyph generation function, but the results are the same.

Also, I updated the feature, checked the Remove Overlap check box, and saved it.

Nevertheless, the combination was broken.
I searched the forum to solve this problem, but I couldn’t find it.
How should I solve this problem?

What do you mean by “broken”? Can you describe step by step what you are trying to do, what you expect as result, and what you get instead?

You didn’t “save” but exported a final font. It is not to be expects to be able to extract all the same information from the .ttf file when you open it.

And overlapping components are decomposed as some rasterizers have problems with overlapping shapes. (It seems that the origin files is made with TrueType outlines and removing overlap from those is not (yet) supported).

  • You open and save .glyphs files. All info you put inside will be kept because .glyphs is a so-called ‘saving format’.
  • You export and import .TTF and .OTF. This is not lossless. Because these are specified formats, they need to follow a specification so other apps can use them as fonts.

Thank you all for your answers.
But I set it up like image number 3 above and sent it out as a ttf file.
When I opened the exported ttf file, the combination was broken and there was an overlap.
The fonts created by others using the glyphs program maintained the combination of alphabets with ogonek and cedilla.
In my case, I want to know the exact cause of this problem why it is not applied.

Is there any way to keep this combination and save it?
If there is, I would appreciate it if you could let me know in detail.

I explained it already.

you can prevent the decomposition by adding this custom parameter to the master or instance: Keep Overlapping Components

I’ve been busy so far, so I’ve only seen the answer now.
When I applied the solution you mentioned, it worked.
I’m so happy that this problem has been solved.
Thank you for your answer.

It’s a fact that I didn’t know. Thank you for letting me know the new knowledge.