Alignment not working

Hi there,

Following an update to Glyphs, it stopped marking when two points are aligned, which it used to do by showing a red line between the two points.

I’ve searched everywhere in the settings and cant seem to find the option to reenable this feature.

Anyone have any clue as to what i (or Glyphs) might have done to switch it off?


Hi Claus,

Thanks! This is a plugin right?

What i am looking for is a feature that used to be there natively in Glyphs. The thin red line would only show up, when nudging the points to be aligned. This plugin seems to show the alignment lines at all times.

The Smart Plumblines plugin only shows the vertical and horizontal lines when you have a node|anchor selected.

I think you mean this, right?

This is a setting per font, your current font might have it turned off. There is a plugin that offers a UI for this setting: Snapper

If you don’t want the plugin, there is also a snippet to set it via the macro panel …

Hi Mark,

Thanks for your answer. And sorry for the late reply.

It is something like this i am looking for. Previously it has just been there in Glyphs, without me turning anything on or off.

I’ve tried the snapper plugin, and it works to sort - but how do i turn the original feature on or off per font?

Snapping should be enabled by default for new documents.