Arabic / ligatures / anchors / marks


I have created a ligature in my Arabic font: reh-ar alef-ar = reh_alef-ar.liga where the alef-ar flips vertically
please refer to the attached screen shots for more details
I have placed this ligature in the features liga as shown in the screen shot
my problem is that when I add anchors to this ligature (cmd + U) it adds only one top and one bottom unlike in the lam_alef-ar where 2 tops and 2 bottoms are added directly
is there a solution for that? anything wrong Im doing?

thank you…


The screenshot is missing.

screen shots attached…
my bad…


You don’t need the liga suffix.

It should add the proper anchors but if it doesn’t, just add them yourself, or copy paste them from another ligature.

well I have tried that already…not adding .liga and placing the anchors myself… it looks fine on glyphs but when exported it doesn’t work neither on illustrator nor on Indesign… the ligature looks as if it has no anchors


Can you send me the file?

will send it to you right away to support@…
my anchors and marks are still not final… so excuse the mess…


That seems to be a problem with Glyphs 1, the anchors work as expected in Glyphs 2.

I can’t download glyph2 since I’m working on so 10.7
is there any other solution / trick / script to make it work?
thank you…


The easiest would be to not use a ligature. Just make an alternate alef and add a context substitution to put it in after a reh.

was about to send you that I solved it using the contextual alternate
thank you
but I think it is unfair and frustrating that using Glyphs 1,4,5 wont give you the same advantage as using Glyphs 2.0… too bad


What would be the point of releasing a new version if it hadn’t more features than the old.

yes sure but I meant what wouldnt Glyphs 2.0 work for older OS??


Glyphs 2 does not run on older OSes because it uses functionality not available in older versions.

ok, too bad for that…all the best of luck always in developing newer versions… my loss :slight_smile:
I hope the new topic I opened isnt also affected by the version number… :frowning: