Arabic Marks (Tashkeel) test preview problem


#1

Hi there.

I’m facing a problem that when I wont to try the font on text preview on Glyphs app appears as below screenshot:


#2

Did you switch to RTL mode? (Buttons onnthe bottom.)


#3

yes I did.54%20PM


#4

You need to remove the marks. I had a script that could do that, somewhere.


#5

Hi,
Can I have it?
Thanks


#6

I added it to GitHub: https://github.com/schriftgestalt/Glyphs-Scripts/blob/master/Helper/Separate%20Letters%20and%20Marks.py


#7

Hi,

Thank a lot,
but how it works?


#8

Type or paste your text in Edit view, run the script.

Or do you need help installing it? Move it into the Scripts folder that appears when you choose Script > Open Scripts Folder. Then reload the scripts with Script > Reload Scripts (hold down the Option key).


#9

HI Mr. Mekka.
Ok, thanks, I’ll try to do what you did reply on, and appreciate your support.