Automatic alignment behaviour doubt

Some context first:
I’m doing some fractions with the fraction glyph as a component, the (number).numr as a component and the (number).dnom also as a component. These last two are already a component of a component (not sure if this is common or even a correct practice). The actual curves are drawn in the (number).sups.

I’ve first started to use automatic alignment but as I moved the (number).sups side bearings nothing would happen to the fractions.
Now i’ve disabled the automatic alignment and when I change the sidebearings the fractions are afected.
I thought, when the automatic alignment is deactivated, changing the metrics would not affect the component.
Can someone clarify what’s going on when you activate the automatic alignment?

*I’m not including any image, because I’m not sure how I can illustrate this problem. But let me know if there’s something I can share to help.

When you change the sidebaring in the .sups glyphs, nothing happens because the .dnum and .numr glyphs are most likely not auto aligned.
What I usually do: put the outlines in the .dnom because they usually sit on the baseline. Then use those as components in .numr (and .subs and .sups). This has the advantage that you do not need nested components.
Make sure to enable automatic alignment for the components in the .numr glyphs, this will sync the spacing but lets you move the components up and down.

And you can fine tune the fractions by kerning the .numr/.dnom with the fraction glyph.

Well, .dnom and .numr are autoaligned. Shouldn’t it work this way?
I’ll do it as you describe, but isn’t placing the curves in .dnom, use them as a component in .numr and then using .numr in the fractions still be considered a nested component?

This is a nested component. They are generally allowed and fine to use. But with the numbers and there half alignment it might be better to do the the other way. But can you send me your file that I can see if it works as expected?

Sent to your support email.
Thank you!

Thanks for the file. It seems that the automatic alignment was disabled in the fraction glyphs.