Automatic? component decomposition


I’m building fonts that are quite complex in terms of node and path numbers.

Firstly I’m noticing that otf or ttf exports (when re-imported) don’t seem to keep standard components in tact (eg ÉĔĚÊËĖ etc) and are decomposing. This is is an issue because an /E/ could have several k points in it and I want to keep size down.

Secondly I made a font that is entirely made of components in effort to squash file size. Unfortunately it seems like everything is being decomposed.

What can I do to stop this?

FYI Found some useful info here:

@GeorgSeifert “If you set the pixel glyphs to export, the components will not be decomposed and the problem will be gone.”

I set my component glyph to export but it is still being decomposed in the TTF. Any ideas?

cc @Mark

You might need the Keep Overlapping Components and Keep Transformed Components (in the Instance Settings).

Thanks Georg. Now it keeps components but not at the original size. The component glyph (circle) is to the right.



can you send me the font?

Will do.

The export seems to work. But the import fails. Your exported font is fine.

Thanks for looking Georg!

I fixed the import bug

Thank you