Axes to order fonts in mac menus?

I use Fontlab’s TransType utility to organize fonts and Glyphs for type design and for emergencies. I guess this counts as Emergency: G to save our souls cast aside by TT.

Say in a font genus and say for the Frank Lloyd Wright genus of 10 font families and say those font styles having been grouped by TT are always dumping themselves at the TOP OF EVERY APP’s FONT STYLE DROP DOWN… when i seriously want the edits to be very BOTTOM OF ALL DROP DOWNS. Worse, workload includes testing TT edits in Font Book by adding and removing macOS font families.

Glyphs app to the rescue! Yes, ⌘-I › Font tab › Axes + › select Weight and click hidden to place checkmark. NOW, those additions to FontBook that shoved Regular and other important styles way down in all apps now leave those important styles on top of my new Glyph creations WHERE THEY ARE SUPPOSED TO BE. Great! Every font style grouped in TT now has to be sorted by Glyphs [GROAN]. Until one minute later when any font edit occurs and mission critical Regular styles immediately get shoved down again in all the macOS menus. Back to that Glyphs app Axes check box again… and again… and again… ad nauseum.

Any even minor font change like close and re-open Glyphs results chaos and Glyphs rescue operations, Not to mention systemic eschar, eh. How to make HIDDEN stick? Oh, btw leaving Glyphs open is no help as the hidden checks seem to automatically uncheck until Glyphs performs open action with subsequent ongoing re-checking…

Is there some way that Glyphs can permanently end the Axes › Weight › Hidden war… like FOREVER? Like a script or something/anything to restore sanity everywhere in macOS with a click?

1 Like

I really tried, but I didn’t understand a thing.

Can you write a short, concise summary of your question?

1 Like

Troll, please read question. Font default sort order (the order of font style by default displays regular font style on top) is disrupted by editing fonts with any font app. Even opening and closing a non-regular font style with Glyphs makes the menu systems’ display that non-regular font style move up to replace Regular at the top of that fonts sort order in every app that runs on Mac. NOTE: THAT SORT ORDER RELATES TO EVERY INSTANCE OF EVERY USE OF THAT FONT EVERYWHERE IN MACOS. The only way to restore normal sort is to open that un-sorted-font in Glyphs, then press ⌘-I (info), then select Axes, then select Weight in the drop down, then place checkmark in the hidden box: this is the only way to restore font style sort order disrupted by Glyphs. Or any other font editor, for that matter. Disrupted by simply looking at a font in Glyphs. Is style sort disruption a known Mac disease? What role can Glyphs app play in managing style sort order disease? Other than constant and repetitive repair as noted.

Pehaps, “un-sorted” is non-descriptive. DISASSOCIATED might be more descriptive. Healthy font display in apps keeps REGULAR font style at the top of every style list in apps because REGULAR is the default system font style.

Until Glyphs opens any font file that is not a Regular font. Which corrupts system wide association with that font. Making the Glyphs-edited non-regular font style of that font replace the default system wide style for that font. Displaying the non-regular font style at the top of every system display of style sort for that non-regular font.


THIS GLYPHS ISSUE (bug?) comes up and is particularly poignant trying to build a Symbol font family for the Frank Lloyd Wright Foundation. For example, consider the font family FLW Eaglefeather, that has no symbol font but would benefit from a symbol font style. We have a symbol font family FLW with 4 fonts (Ornaments, Radiants, Sections, Symbols). We simply copy FLW into FLW Eaglefeather.
RESULT: system wide style sort places Ornaments, Radiants, Sections, Symbols on top of Regular
Here we see 4 occurrences of having to run that Info-Axes-Weight-Hidden-Checkbox repair.
RESULT: system wide style sort places Regular where it belongs on top of Ornaments, Radiants, Sections, Symbols.
There are multiple FLW fonts, so multiple repairs.

Is there a Glyphs Preference to permanently stop Glyphs making any change to the DEFAULT system font style sort. The only current fix that I can find is the repetitive and time consuming Info-Axes-Weight-Hidden-Checkbox repair.

I am using Glyphs 3.1.2 (3151) default settings.
Preferences › User Settings?
Preferences › Shortcuts?

1 Like

Sebastian is the farthest away from a troll as possible.
And I was happy with his answer as a shorter, clearer question would help a lot.

And I’m not spending my time trying to understand a post that starts with an insult.


Georg, the biggest insult is having a problem with understanding and being told “No help here because you don’t understand”.

1 Like

Georg, I can see lots of elbow room in your Glyphs’ User Settings preferences. Can these block Glyphs from making system wide changes to font style sort order?

Or, could Glyphs User Settings be developed to include management of system wide style sort order?

Info-Axes-Weight-Hidden-Checkbox repair proves absolutely that Glphs can perform system wide style sort order. It would sure be nice if you gave Glyphs a whole lot more reach and power in this respect. Kindly read EXAMPLE, above. Many thanks for your development interest.

1 Like

Please, instead of writing overly long, convoluted texts with no clear problem description, please just describe your specific problem concisely, ideally accompanied by a visual aid such as screenshots of your issue.

That will help us understand your issue and potentially provide a solution.

So far, what I’ve gathered is that you’re trying to remedy some fonts in Glyphs that you edited in TransType, but something isn’t working. Correct thus far?

1 Like

From what I can understand, it seems you are checking the axis hidden checkbox. Whatever this does to your fonts, this is definitely not a solution. It might coincidentally appear so, but it ain’t.

So your question why this checkbox won’t stick and how to make it stick is already not leading to a solution.

That is why we need to know where the problem really comes from in order to help.

Could you please describe what kind of font sources you use? Do you have a glyphs file properly set up? Or are you opening existing .otf or .ttf files in Glyphs? How do you export your fonts? Into which folder? As which font format?

Also which Mac apps do you try the fonts in? (“All Mac App” is not descriptive, imagine that there is not an absolute “all” for apps. There is always someone having other or more apps than you.)

So if you mind to provide us with the hard facts about what you are exactly doing (basically answer the questions straight), we are definitely able to help you out.

1 Like

Have you read the naming tutorial?

Perhaps also Eliminating font cache problems | Glyphs

It seems like there’s a mix of misunderstanding of how apps sort styles and cache issues.

1 Like