Axis location for virtual masters?

Hello, I am using a few virtual masters in my setup and would like to set their Axis Location parameter, but I can’t. This results in my exported axis range going from 34 (internal smallest weight) to 900 (external largest weight). Is there any way I can remedy this from within Glyphs? Thanks!

Virtual masters can’t have axis mapping. You just need to set them up for the expected external value. Can you show your master setup and what you use the virtual masters for?

It’s a font with only three glyphs. One of these glyphs has a width and ascender height axis, so I set three virtual masters (because I have a weight axis for all glyphs). This means:

  • Master 1: weight min, width min, asc min
  • Master 2: weight max, width min, asc min
  • VM1: weight min, width min, asc max
  • VM2: weight min, width max, asc min
  • VM3: weight max, width max, asc max

I’ll send you the file shortly. It’s the same file I opened another topic on (viewing intermediate layers).

You only need one virtual master. With weight min, width max and asc max.
About the mapping I need to play with your file.

Sorry, only got back to this now. I have the following:

  • Master 1: wght0, wdth0, ytas0
  • Master 2: wght1, wdth0, ytas0
  • VM 1: wght0, wdth0, ytas1
  • VM 2: wght0, wdth1, ytas0
  • VM 3: wght0, wdth1, ytas1
  • VM 4: wght1, wdth0, ytas0

I’m sure this is not correct. I’ve sent you the file (Telegram), thanks a lot!

You need one Virtual Master parameter. And leave the Weight field empty.

It is not really a master. It is just a way to define axes ranges in cases like this where those locations are only used by intermediate layers. The axis ranges could be deduced from the intermediate layers, but they need to be know in advance.

Great, thanks a lot!

Following up on this. I need to define axis location parameters for the Width axis (for which I don’t have a proper master), as InDesign doesn’t display the font correctly in the regular weight/width. I suspect the reason might be that the normal width axis location is not set to 100.

Is this possible from within Glyphs?

you need to use the “proper” values in Glyphs already. So instead of 2–8, use 50–200 (or whatever range you like to use).

Alright, thank you, good to know.