Bad CharString format

I appear to have made a change to my font that is causing an error, but I can’t find it. It manifested when I tried to export the font. As OTF, the font simply appears empty with no glyphs. As TTF, I get the following from running generateFont.command:

makeotfGlyphs [FATAL] — Source font: font.pfa
makeotfGlyphs [FATAL] bad CharString format

No Google searches turn up any hints. Anyone here have any idea?

Can you send us the .glyphs file? support at this domain

Please add the glyphs .notdef and space to the font if you like to export as TTF. I fixed the bug that caused this makeOTF error.

OTF export works fine with Glyphs Version 1.4.4 (587) on OS X 10.9.2. For the TTF export to work, you need to include a glyph called “space”.

Georg: /.notdef was added automatically in my case.

Thanks, that did it. Is this documented? I didn’t see it in the manual.

It is not necessary to add both glyphs. It was a bug, it should work without manually adding the glyphs.

Many thanks. All export problems solved!

I got this error message today because my font contained a (some) blank glyph(s) with empty name(s) by mistake.
Any way to avoid generating such empty glyphs? They could came up by duplicating multiple glyphs in text view (?) or by too many spaces in a generate glyphs string.

If you tell us step-by-step how you generated those glyphs, we can try to prevent it. Glyphs already prevents deleting a glyph name.

I thought rather of a general check for those empty glyphs e. g. after ⌘-G action or ⌘-V action.
I will try a step-by-step on the bug-report site.