Big bug on a complex font

Hello !

I have a little problem : when I use my complex font (outside of Glyphs) (so InDesign, Illustrator but also Webfont test), characters is completely destroyed (see screenshots). But this problem appeared today, a month (see more) after having touched my file so it is perhaps since the last update (knowing that I did not make huge changes except having to check the export of some diacritics).

Thank you :))

Hard to help with little information. Do you have an idea what the problem is? How is the font constructed? With components? Did you get a component alignment dialog when you opened the font?

Did you export as OTF or TTF? Did you make sure to disable hinting?

Which versions of Glyphs (before and after)?

How are you installing and testing the font?

  • I don’t have an idea what the problem is

  • The font is constructed partly with components :

  • I get a component alignment dialog when I opened the font yes, but for only one character, not the characters where we have the problem

  • I export as OTF, hinting disabled

  • I don’t know the version before but it’s actually 3.2 version of Glyphs

  • I show you how I installe the font :

For testing, I use the font on Indesign typing words/letters…

It’s weird…

Looks like some components are aligned by their anchors when they are not supposed to be aligned.

Try Glyphs > About Glyphs.

1 Like

Do you mean that it isn’t working in 3.2 and it did in an earlier version? Then you might like to go back to that earlier version for now. It is still in beta and there probably some issues here and there. here is a link to the latest stable version:

But can send me that file? I’ll like to see if I can fix the problem.

1 Like

It worked in an earlier version, I didn’t have this problem before. But yes in 3.2, when I export this problem exist.

Thank you I will try with the latest stable version.

I can send you that file yes thank you !

It works good in the latest stable version !

Thank you @GeorgSeifert :))

I just uploaded a new version that fixed it.

1 Like