Block shadow effect

There’s a way, or rather a plugin/script to add a Block Shadow quickly to the Glyph? Because shadow’s plugin generates an offset copy and I would like to have 3d sign-painting effect.

I’m working on a filter like this but it is not finished, yet.

1 Like

Yes: Rotate, add extremes, cut at extremes, pull apart, and reconnect the open ends. For now, you will have to do this manually, I am afraid.


My aim was to “generate” something like that, with angular outline and drop shadow

Came to the forum to ask about this as well.
Too bad nothing seems to be available at this point.

Bumping with the same request: Solid drop shadow effect?

Checking in on this…
I really don’t want to do it manually :frowning:

The diagonal extrusion is non-trivial for creating automatically.

If you want a drop shadow, you can use the Shadow plug-in in Window > Plugin Manager.

Take a look at my “Make Block Shadow” script at my repo: GitHub - harbortype/glyphs-scripts: An assortment of scripts for the Glyphs font editor

It is not perfect but will help you out in most cases.



Hello, your script seems to be fantastic, but I’m unable to run it effectively. Every time I try it just crashes the whole app. I’m using the latest version, 3.0.4 (3100), and just reinstalled the Vanilla, Fonttools and RoboFab modules, with no effect whatsoever.

G3 [3100]. I just installed it and tried it. No crash here, but it doesn’t do anything. I posted an Issue on his repo about it.

Traceback (most recent call last):
File “Make Block”, line 9
import vanilla, math, numpy
ModuleNotFoundError: No module named ‘numpy’

Have you tried the “Extrude” filter?

For making only a shadow Extrude works perfectly.

If you need something that needs numpy, you need to install python yourself (the version from it good) and install pyObjc and numpy yourself.

Apologies for the late reply. I have just published a fix for Make Block Shadow when running in Glyphs 3.

Thank you for opening an issue on the repository. The script does not need numpy, so I removed the import. But the thing that really broke the script was a change on how path segments are implemented in Glyphs 3. It should work now.

Many thanks for the update, now it’s working!